Jump to content
cheires

Servidor debian desliga-se sem razão aparente

Recommended Posts

cheires

Olá a todos,

Tenho um servidor Debian 6 com kernel 2.6.32-5-amd64 que funciona bem durante uns dias mas depois, e sem que nada (externo pelo menos) contribua para isso, desliga-se.

Isto já acontecia com um SO Debian também mas na versão 4, que depois de ter ficado mal actualizada resolvi reinstalar o SO e passar para a versão 6.

Pensando que se trataria do Cron a executar alguma operação de shutdown desliguei o Cron, mas mesmo assim o computador continua a desligar.

Já verifiquei todos os log e não há nada que indique o que se possa estar a passar, não houve quebras de energia, nem nenhuma operação que fizesse o servidor desligar-se.

O que se poderá estar a passar com isto?

Agradeço antecipadamente todas as ajudas

Abraç a todos.

Share this post


Link to post
Share on other sites
cheires

É possível, mas o que causa que um servidor se desligue depois de uns dias a funcionar normalmente?

Todos os dissipadores funcionam (aparentemente), por isso não deve ser problema de aquecimento.

Se fosse problemas com memórias ou CPU ou mesmo Board, penso que isso daria logo problemas de arranque, e nem iniciaria o SO.

Não tem qualquer outro periférico instalado.

Share this post


Link to post
Share on other sites
KTachyon

Nos logs, nada?


“There are two ways of constructing a software design: One way is to make it so simple that there are obviously no deficiencies, and the other way is to make it so complicated that there are no obvious deficiencies. The first method is far more difficult.”

-- Tony Hoare

Share this post


Link to post
Share on other sites
pedroserra

É possível, mas o que causa que um servidor se desligue depois de uns dias a funcionar normalmente?

Todos os dissipadores funcionam (aparentemente), por isso não deve ser problema de aquecimento.

Se fosse problemas com memórias ou CPU ou mesmo Board, penso que isso daria logo problemas de arranque, e nem iniciaria o SO.

Não tem qualquer outro periférico instalado.

Tive um portátil com problemas de memória que ao final de umas horas reiniciava inesperadamente.

Experimenta passar isso com o memtest, por via das dúvidas....


Ah e tal não sei quê...

Share this post


Link to post
Share on other sites
cheires

Nos logs, nada?

Nada. Pelo menos nada que indique um shutdown ou algo do género.

No syslog e no messages não têm qualquer ocorrencia desde que se liga uma vez, até à proxima vez que se volta a ligar.

Ou seja, pode indicar que o shutdown não tem origem no software. O que pode ser realmente um problema de hardware.

Tive um portátil com problemas de memória que ao final de umas horas reiniciava inesperadamente.

Experimenta passar isso com o memtest, por via das dúvidas....

O problema é que isto não reinicia, desliga-se mesmo.

Em todo o caso vou efectuar o teste às memórias.

Share this post


Link to post
Share on other sites
anolsi

Não pode ser um problema de sobreaquecimento?


"Nós somos o que fazemos repetidamente, a excelência não é um feito, e sim, um hábito."
Não respondo a questões por PM que possam ser colocadas no fórum!

Share this post


Link to post
Share on other sites
cheires

Teste de memória feito e passou sem qualquer erro.

Quanto ao problema de sobreaquecimento, não me parece que seja, pois todos os dissipadores trabalham normalmente. O local onde s encontra é devidamente ventilado, e sem janelas. A temperatura ambiente andará pelos 15-18 ºC.

Share this post


Link to post
Share on other sites
pedroserra

O mistério adensa-se...  :)

Uma ideia que surgiu aqui no escritório: senhora das limpezas a precisar de uma tomada? (ou algo parecido)


Ah e tal não sei quê...

Share this post


Link to post
Share on other sites
terramoto

Esse tempo que aguenta ligado é random ou ronda à volta do mesmo tempo? Pode ser a MBoard, já tive uma máquina que desligava-se do nada e só depois ao longo do tempo é que começou a falhar no arranque. Pode ser da fonte também, acho que qualquer outro hardware mostrava erro nos logs ou simplesmente congelava a imagem.


A great truth is a truth whose opposite is also a great truth.

Share this post


Link to post
Share on other sites
cheires

O mistério adensa-se...  :)

Uma ideia que surgiu aqui no escritório: senhora das limpezas a precisar de uma tomada? (ou algo parecido)

Não, isso não é, pois a tomada fica em local de acesso difícil, e elas não estão para se dobrar muito.

Esse tempo que aguenta ligado é random ou ronda à volta do mesmo tempo? Pode ser a MBoard, já tive uma máquina que desligava-se do nada e só depois ao longo do tempo é que começou a falhar no arranque. Pode ser da fonte também, acho que qualquer outro hardware mostrava erro nos logs ou simplesmente congelava a imagem.

O tempo que permanece ligado é totalmente random, tanto pode ser uma semana ou mais, como um dia.

Mas ele encerra? Ou o computador desliga-se?

Penso que se desliga. Pois se encerrasse essa operação aparecia nos logs.

Pergunta, é possível o Debian sem qualquer instalação de pacotes visuais (X) poder entrar em hibernação ou suspensão?

É que tirando as avarias de hardware (que não me parece que seja o caso), foi esta ideia que me passou pela cabeça.

Share this post


Link to post
Share on other sites
falco

Penso que pode hibernar, ou suspender, mas não o faz nunca por iniciativa própria e de qualquer forma os logs diriam algo...

Eu apontava para problemas de hardware, mas não te sei dizer qual...

Sabes dizer se a máquina está idle quando desliga?

Share this post


Link to post
Share on other sites
Rui Carlos

É possível, mas o que causa que um servidor se desligue depois de uns dias a funcionar normalmente?

Todos os dissipadores funcionam (aparentemente), por isso não deve ser problema de aquecimento.

Se fosse problemas com memórias ou CPU ou mesmo Board, penso que isso daria logo problemas de arranque, e nem iniciaria o SO.

Há uma infinidade de problemas de hardware possíveis, muitos bastante complicados de detectar.

Problemas da memória ou CPU e afins nem sempre se manifestam no arranque. Já vi casos de problemas de memória que levavam a que o PC volta e meia tivesse que ser reiniciado, ou outros problemas que causavam erros de modo mais ou menos aleatório com a board. Também já vi problemas com maus contactos de fios.

Podes experimentar colocar outro SO, a ver se o problema é do software, mas acho muito pouco provável.

Share this post


Link to post
Share on other sites
apocsantos

      Boa noite,

      Eu descartaria software como problema. Penso que o problema possa estar na fonte de alimentação... Sobre-aquecimento dos condensadores, pode levar a um comportamento anómalo da fonte que por sua vez corta a corrente.

    A explicação para os "randoms" pode ter a ver com a carga de trabalho... Como provavelmente estás a usar a gestão de energia, ele regula o consumo de energia (e consequente esforço da fonte), pela carga de trabalho que tem, de acordo com as necessidades.

    Eu faria uma serie de testes de carga ao servidor (ler, gravar, apagar) dados, em loop durante algum tempo e monitorizaria de perto o seu comportamento durante estes testes. Adicionalmente poderia puxar pela placa de rede (enviar grandes quantidades de dados via rede), também para obrigar a board a puxar pela fonte.

      Assim seria mais fácil despistar qual o problema.

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites
cheires

Antes de mais, quero agradecer a participação de todos.

Todas as sugestões foram tidas em conta, e, como ainda o problema não foi devidamente detectado, são todas válidas.

Ontem matei o acpid, e ainda está a funcionar, por isso é esperar para ver.

Vou dando novidades.

Share this post


Link to post
Share on other sites
cheires

Voltou a ir abaixo....

Houve alguém que mencionou problemas na board, para causar carga no servidor para ver se eles se manifestam.

O servidor desliga-se nas horas de menor carga, durante a noite mesmo (pelo menos é essa a indicação que dá ao ver os log)

Share this post


Link to post
Share on other sites
apocsantos

    Bom dia,

    Sempre nas horas de menor carga (maior latência) ?? Se for esse o caso desactiva-lhe a gestão de energia. Já me aconteceu isso no passado. A gestão de energia, causava um mau-funcionamento da board, que por sua vez indicava à fonte que desliga-se a corrente.

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites
cheires

    Bom dia,

    Sempre nas horas de menor carga (maior latência) ?? Se for esse o caso desactiva-lhe a gestão de energia. Já me aconteceu isso no passado. A gestão de energia, causava um mau-funcionamento da board, que por sua vez indicava à fonte que desliga-se a corrente.

Cordiais cumprimentos,

Apocsantos

Já efectuei essa operação, e por uns dias pensei que o problema tinha sido resolvido, mas depois....

Voltou a desligar-se.

Share this post


Link to post
Share on other sites
apocsantos

    Boa noite,

    Posto isto creio que a Board esteja danificada. Se puderes indicar qual o hardware (marca, potencia da fonte e se está numa configuração de duas fontes redundantes ou não), será mais fácil dar mais informação.

    Pode eventualmente ser um problema de oscilação da corrente 220v-230v que esteja a causar esse mau funcionamento, mas também não sei se estás a usar UPS's on-line com filtragem.

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.