Jump to content
tibi

Problema ao gravar imagens com extensão com letra maíscula

Recommended Posts

tibi

Ola boa noite!

Estou a ter problemas a guardar imagens através de um painel de administração, pois elas estão com a extensão em letras maiúsculas (.JPG) e isso cria erros.

No código permito inserir jpg, gif ou png, mas não sei como corrigir este erro.

Alguma sugestão?

Para mim, gravava novamente as imagens em .jpg, mas o cliente nem sempre faz isso  e bem vendo o erro... entra logo em contacto

Share this post


Link to post
Share on other sites
anolsi

Basta ao verificares a extensão, antes aplicares a função strlower à extensão do ficheiro dado, e só depois então fazeres a comparação.


"Nós somos o que fazemos repetidamente, a excelência não é um feito, e sim, um hábito."
Não respondo a questões por PM que possam ser colocadas no fórum!

Share this post


Link to post
Share on other sites
tibi

Obrigado pela resposta.

Ja tinha tentado colocar essa função, mas devo estar a coloca la no sitio errado.

// verifico o nome do ficheiro:

$name = $_FILES[$field]["name"][$i];

// verifico a extensão:

$ext = substr($name, strlen($name)-3, 3);

Já tentei colocar a função no $name e no $ext e ao fazer um "echo" (quando gravo a imagem) da me um resultado com letras minúsculas, mas também me aparece o erro:

124 105141 (1).jpg

Fatal error: Allowed memory size of 10485760 bytes exhausted (tried to allocate 10684 bytes) in C:\xampp\htdocs\autocoelhinho_cms\includes\images.php on line 35

Mas quando retiro a função strtolower o erro sai.

Share this post


Link to post
Share on other sites
tibi

já testei online e não me dá nenhum erro!! :D

Mas acho que ainda não esta a 100%, pois noto uma lentidão fora do normal para carregar imagens.

Possivelmente terei algum ciclo um pouco mais pesado do que o normal...

Mas vai-se resolvendo aos poucos.

Obrigado pela ajuda  :P

Share this post


Link to post
Share on other sites
tibi

Olá, não tinha respondido porque tive uma semana ausente de codigos...  ;)

Sim, isso é normal, testei com fotos de 2 megas e é normal que demorasse tempo e ja coloquei um limite, mas como permito ao cliente inserir 5 fotos ao mesmo tempo, o upload tornava se lento na mesma. Mas ja lhes expliquei a situação, eles agora carregam fotos mais leves.

Mas obrigado na mesma

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.