Jump to content
vitropor

Configuração PHP + SQL

Recommended Posts

vitropor

Ora Boas malta.

Peço desde já desculpa se reabri novo tópico com possivelmente algum já esxistente.

Mas neste momento encontro-me em estágio professional e necessito urgentemente da vossa ajuda!

Eu sou iniciante em programação de páginas WEB por isso peço a vossa total paciencia :P .

Estou numa empresa a estagiar e a empresa tinha um site alojado só que entrentanto deixou de pagar esse mesmo a alojamento e ele foi ao ar.

Entretanto foi-me pedido novamente para fazer o alojamneto do site num dos vários servidores free existentes e é isso que eu gostaria de fazer.

Só que o problema é o seguinte:

O site foi desenvolvido por uma empresa que neste caso é a “Seara” e no acto do pagamento após o seu desenvovimento foi-me entregue um CD com todos os ficheiros pertencentes a esse mesmo site, ou seja, o site está prontinho para ser alojado só que eu não estou a conseguir faz-lo.

Eu antes de começar a pesquisar sobre um servidor free que seja aceitavel para fazer o alojamento tentei testa-lo localmente e para isso estou a utilizar o WAMPSERVER, e o DREAMWEABER para fazer a conexão à base de dados tal como vi em alguns tutorias disponiveis na internet.

Configurei devidamente o “ localhost” colei a pasta com os  ficheiros e respectiva base de dados do site no directório padrao do WAMPSERVER que é “C:wamp/www/httpdocs” httpdocs que é a pasta que contém todos ficheiros.

Atravéz do phpMyAdmin importei a base de dados correspondente ao site e ela foi importada com exito, depois utilizei o DreamWeaver também configurado para “correr” localmente, carreguei o site e fiz conexão à base de dados, fiz tudo passo a passo como vi nos tutorias e nada.

Quando vou para testar, abre um ficheiro Flash que é uma pequena apresentação da empresa, e quando escolho umas das opções (Português, Espanhol e Inglês) as imagens não são carregadas e o texto apareçe todo desformatado e com caracteres especiais.

Por favor alguém que me ajude porque eu já não sei mais o que fazer.

Desde já obrigado e um abraço a todos.

Share this post


Link to post
Share on other sites
mAiN_iNfEcTiOn

O problema que indicas aparenta ser do caminho das imagens estar incorrecto...

Clica com o botão em cima da imagem não carregada (ou seja daquele icone manhoso que é posto a substituir) e vê qual o caminho da imagem.

Abraço.

OFF TOPIC:

SEARA?!?!?!? WTF!?!?!?! ;)

Share this post


Link to post
Share on other sites
vitropor

;) também não conheço a empresa, só sei que me querem cobrar uma fortuna só para ver o que se passa com isto.

Caro amigo, desde já muito obrigado por me estares a tentar a ajudar, sim ja fiz isso em muitas dessas imagens e mesmo assim não são carregadas. Eu penso que o problema esteja na ligação à Base de dados porque pelo código que eu vi, eles usam variaveis para a opção das linguas (Portugues, Espanhol e Ingles) que pretentedmos escolher e a escolha dessa lingua vai buscar uma imagem diferente das outras linguas, não sei sei me estás a entender .

Se quiseres ter uma ideia do que se passa, (um colega meu andou a inventar) :D ..

Vê aqui www.vitropor.tk

Obrigada abraço

Share this post


Link to post
Share on other sites
Bessa

O colega que andou a inventar fui eu... :cheesygrin:

De referir que, o que fiz foi criar uma conta no Alojamento FREE que suporta PHP, MYSQL e aceita que se faça Upload de files até vários MB (Não sei ao certo), e então procedi ao Upload dos ficheiros por FTP. No Entanto, como cada pasta tem inúmeros files, chegava a um certo ponto que dava erro de não conseguir conectar-se ao Servidor e mesmo que fizesse reconecção dava sempre erro de que excedeu o tempo normal de se ligar ao server...

E por isso, apenas ficou os files tipo index.html, a imagem Flash e mais umas pastas no Servidor.

Penso que se o Upload fosse concretizado a 100%, isto é todas as pastas e subs pastas e sub sub pastas fossem lá colocadas, que o site rodaria. Ou estarei enganado?

Cheguei a fazer Upload do file .sql que lá está incluído.

Desconfio que o problema das falhas de ligação para com o Server, seja mesmo do próprio servidor, dado que não estava a utilizar Download e Upload pouco estava (Para aí 15 KB, tenho 100KB).

Share this post


Link to post
Share on other sites
vitropor

Não fui eu que fiz aquele upload foi um colega meu que tem a mania que é artista  :cheesygrin:

Mas penso que não seja ísso, cheira-me que ha mais qualquer coisa ;)...

O site tem 13 Mb, posso-te enviar o link para sacares os ficheiros e das uma espreitadela??? LOL

Obrigada, abraço

Share this post


Link to post
Share on other sites
mAiN_iNfEcTiOn

Aconselho-te profundamente a tirares o ficheiro .sql dali ;)

Senão poderás estar a fornecer dados para fora, que possam ser confidenciais.

Quanto ao 'não conhecer a empresa', eu conheço....

... simplesmente já não morro de amores por ela :D Ah uns tempos, queria ir para lá trabalhar, não consegui porque era novato, mas passou o tempo e comecei a ouvir pessoal que lá trabalha a queixar-se da empresa... pode não ser verdade, mas que eles lá trabalhavam, trabalhavam!

Share this post


Link to post
Share on other sites
vitropor

LOL, tirando essa empresa são todas ;) , hoje em dia toda a gente se queixa.

Quanto ao meu site, o que achas-te que possa ser?

eu vou remover o ficheiro .sql apesar de não ter nada de especial

Share this post


Link to post
Share on other sites
Lfscoutinho

Boas,

eu vou remover o ficheiro .sql apesar de não ter nada de especial

Se achas que a tua base de base de dados não é nada especial, então está bem..  ;)

Quanto ao problema, é vergonhoso uma empresa colocar um site num alojamento grátis, quando existem tantos nacionais e a preços tão acessíveis. Em vez de estares a queimar miolos com isso, devias-te concentrar em convencer o teu "patrão" a comprar uma conta de alojamento. Caso contrário, procura outro alojamento grátis, mas não esperes dele o que podes esperar de um pago.

Share this post


Link to post
Share on other sites
vitropor

Sim tens razão, eu ja lhe falei disso mas ele não quer  ;) .... não posso fazer nada quanto a isso.

Só que como ando em estágio, gostava mesmo de colocar isto a dar, porque o site está prontinho eu é que sou um grande

nabo e não sei configurar esta porra num servidor  :confused:

Já consultei N de tutorias e não consigo por isto a dar.

Qual o servidor free que me aconçelhas para alojar um site php + sql?  e já agora um pago ....

já estou por tudo :S

Obrigada abraço....

Share this post


Link to post
Share on other sites
Lfscoutinho

Boas,

Pagos tens a PTServidor, Trignosera, Iberweb, etc...

Procura no Google por "alojamento nacional" e vais encontrar muitos mais!

Gratuitos existem MUITOS, a maioria internacionais, basta fazeres uma procura por "free web host" e pronto...

Lembro-me que uma vez utilizei um chamado "byethost", acho que era assim, para fazer uns testes e nunca tive problemas...

Mas... é melhor um pago !

Atenção: eu não tenho nenhuma ligação a nenhum dos alojamentos que referi, simplesmente foi dos que me lembrei.

Share this post


Link to post
Share on other sites
vitropor

Boas caro amigo.

Sim, já andei à procura e encontro realmente muitos servidores que alojam free.

O problema é quando me mandam o email para activar a minha conta criada no site, que a maior parte deles pedem para

efectuar o pagamento.

O que queria, era colocar o site online e minimamente funcional.

Porue tanto o meu "patrão" como eu sei que daqui a "meia-duzia" de dias ele vai ao ar.

Só que como estou em estágio ficava bem eu conseguir fazer este alojamento com sucesso, entendes ? ;)

O problema é só no alojamento, porque o site está pronto desde de 2004 :confused:

Pensei que ia ser simples, e não está a ser pera doce, pelos menos para mim lool

Abraço

Share this post


Link to post
Share on other sites
Bessa

Se queres Alojamento FREE, vê este site:

http://www.free-webhosts.com/no-forced-ads.php

Nessa lista vês os que aceitam PHP e MYSQL.

Nessa lista não tem WebHosts que contenham Publicidade, isto é, muitos dos que existem, em troca de alojamentro FREE, metem-te publicidade que deus me livre ou Pop-Ups cada vez que se abre o site ou Banners de Pub, aí são sites FREE sem esse tipo de Pub. :confused: Assim nada faz parecer que é FREE, em termos da visualização dos visitantes.

Não te registes no que disserem isto ou Algo do Género:

"All free web hosting signups are manually verified before being approved." -> Dado que podem demorar a ativar a tua conta;

"30-days Inactivity limit." - Por exmp, se não fizeres Login no site 1 vez em 30 dias, o site vai de vela... lol

Continuo a achar que se fizeres upload de tudo, o site fica a funcionar. :D Tens é de perder tempo, mas se o objetivo que te deram é alojar o site, tempo é o que mais tens.  Em 1 Dia alojas tudo! LOL

;)

Share this post


Link to post
Share on other sites
vitropor

Já fiz esse alojamento todo direitinho, fiz upload aos files do site e à respectiva base de dados.

Tudo direitinho, agora só me falta registar os dominios para o testar.

Andas rico Bessa  nem respondes às sms nem mails nada. 😡

Obrigado abraço

Share this post


Link to post
Share on other sites
Bessa

Mas tu pensas que trabalho onde?

E só estou aqui no P@P porque é um fórum que não tem nada que poderia ser limitado e porque me tem ajudado muito na minha adaptação ao VB 2008. Senão, nem aqui conseguiria estar! :confused:

Não há cá nada de Tlms ou Msn, mails ou sites com conteudos de distração... ;)

Mandei-te PM com os dados que necessitas para os domínios

Share this post


Link to post
Share on other sites
vitropor

Amigo, eu encontro-me sempre tão limitado como tu....

Só que há sempre como dar a volta por cima  :cheesygrin: ....

Menos para este problema que eu estou para aqui a relatar, não sei mesmo o que se passa com isto.

Precisava de ajuda de uma pessoa que perceba realmente disto :S

Obrigada abraço

Share this post


Link to post
Share on other sites
vitropor

Caro amigo Coutinhio, enviei-te um email para o que forneçes na tua "apresentação"

Se pudesses dar uma olhadela ficaria-te muito grato.

Obrigado  ;)

Share this post


Link to post
Share on other sites
IvanGS

Já fiz esse alojamento todo direitinho, fiz upload aos files do site e à respectiva base de dados.

Tudo direitinho, agora só me falta registar os dominios para o testar.

Andas rico Bessa  nem respondes às sms nem mails nada. 😡

Obrigado abraço

já foste ver se o domínio já está a ser utilizado?

Share this post


Link to post
Share on other sites
vitropor

Boas...

O que fiz foi o seguinte:

Criei uma conta aqui

http://www.dot.tk/pt/index.html?lang=pt

Foi a "Meus Domínios", Adicionar um novo domínio, e adicionei o domino.

Depois no dominio do servidor onde está o site:

Alterei (Antes tava vitropor.freezoka.com. e fiz rederecionar para vitropor.tk)

Isto já está a dar, só que a página que abre continua a pedir um novo dominio :S

desculpem se estou a ser nabo... mas eu n percebo muito disto

Obrigada abraço

Share this post


Link to post
Share on other sites
vitropor

Hummm lá onde crei o Dominio falava lá de qq coisa dos Dns para utilizar.

Vou la e meto para utulizar o Serviço DNS Dot TK gratuito?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.