Jump to content
ordepavr

página bloqueada com o "www"

Recommended Posts

ordepavr

Boas, estou neste momento em estágio em Itália e a entidade está com um problema que, apesar de não ter a ver com aquilo que estou a fazer, gostaria de os poder ajudar.

O problema consiste em:

De vez em quando, o website é alvo de ataques (pelo menos foi assim que me foi explicado o problema) e após isto, o website deixa de funcionar. No entanto, se colocar-mos o url sem "www", ele entra no website.

Gostaria de saber se alguem tem uma explicação e uma solução para este problema.

Grato pela atenção

Cumps, Pedro L.


"Programming is like sex: one mistake and you're providing support for a lifetime.""A exigência conduz à excelência"

Share this post


Link to post
Share on other sites
IvanGS

isso é o servidor mal configurado...

a empresa onde estás tem os servidores aí ou aluga-os?

Share this post


Link to post
Share on other sites
ordepavr

Ta num server da empresa.


"Programming is like sex: one mistake and you're providing support for a lifetime.""A exigência conduz à excelência"

Share this post


Link to post
Share on other sites
Lfscoutinho

Boas,

Isso não é um problema. Isso é configurável.

Podes permitir que o utilizador seja obrigado a escrever o "www.", obrigado a não escrever o "www." ou que possa utilizar as duas formas (isto é o que costuma estar por defeito).

Share this post


Link to post
Share on other sites
ordepavr

Podes-me explicar onde vou configurar isso? Eles querem que funcione com www e sem www.


"Programming is like sex: one mistake and you're providing support for a lifetime.""A exigência conduz à excelência"

Share this post


Link to post
Share on other sites
Lfscoutinho

Boas,

Então, isso é o que está por defeito.

Se estiverem a usar o cPanel, é nos redireccionamentos.

Share this post


Link to post
Share on other sites
ordepavr

obrigado


"Programming is like sex: one mistake and you're providing support for a lifetime.""A exigência conduz à excelência"

Share this post


Link to post
Share on other sites
mAiN_iNfEcTiOn

:) Embora o correcto seria ter no vhost onde tem:

ServerName dominio.tld

Ter também:

ServerAlias www.dominio.tld

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.