Jump to content
Elrosnum

Conexão à BD com C#

Recommended Posts

Elrosnum

Boa tarde a todos =]

Depois do VB virei-me agora para o C# e no projecto que estou a fazer, deparei-me com um problema.

Já estive a procurar algumas coisas aqui no fórum, encontrei isto (http://www.portugal-a-programar.pt/index.php?showtopic=1557) mas não me tira a dúvida pois já testei o código e não funciona =X

O problema gostava de saber como eu me posso ligar a uma BD feita em SQL Server 2008 mas sem ser em OLEDB, ligação normal, parecido ao VB?

É possivel?

Se sim como?

Se me puderem ajudar agradecia imenso =]

Obrigado

Share this post


Link to post
Share on other sites
nando4

Eu uso SQL SERVER 2005 mas deve ser igual.

Experimenta assim:

//ligacao a BD
static string ligacao_str = "server=User-PC" + @"\" + "SQLEXPRESS;Database=teste;User Id=nome_user;Password=*****";
SqlConnection liga = new SqlConnection(ligacao_str);

Não te esqueças de adicionar isto primeiro:

using System.Data.SqlClient;

Cumps

Share this post


Link to post
Share on other sites
Elrosnum

Boas nando4, só agr é que cheguei a casa...

Vou testar e já te dou algum feedback =]

De qualquer das maneiras agradeço-te imenso :thumbsup:

Share this post


Link to post
Share on other sites
Elrosnum

Dá- me um erro " Expected Class, delegate, enum, interface, or struct"

Eu não tenho bem a certeza onde devo meter esta linha, eu ja meti o using System.Data.SqlClient

E meti esta linha antes do namespace...

Podes-me dizer o sitio correcto sff?

Desculpa a ignorância =X

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.