Jump to content
Sign in to follow this  
luiscastro

Ligar Web Service a Base Dados SQL Server 2008

Recommended Posts

luiscastro

Boa tarde.....

Preciso ligar um ASP.NET web service a uma base dados Sql Server 2008, em C#

Estou a usar este código:

public void aaa()
        {
            //metadata=res://*/Model1.csdl|res://*/Model1.ssdl|res://*/Model1.msl;provider=System.Data.SqlClient;provider connection string="Data Source=LUISCASTRO-PC\SQLEXPRESS;Initial Catalog=DB_Metereologia;Integrated Security=True;MultipleActiveResultSets=True"
            
            // create a new SqlConnection object with the appropriate connection string
            //SqlConnection sqlConn = new SqlConnection("Integrated Security=SSPI;Initial Catalog=northwind");
            SqlConnection sqlConn = new SqlConnection("Data Source=LUISCASTRO-PC/SQLEXPRESS;Initial Catalog=DB_Metereologia;Integrated Security=True;MultipleActiveResultSets=True");
            
            // open the connection
            sqlConn.Open();
            System.Diagnostics.Debug.WriteLine("Base de Dados Aberta");
            // close the connection
            sqlConn.Close();
            System.Diagnostics.Debug.WriteLine("Base de Dados Fechada");
        }

Mas dá-me este erro:

An unhandled exception of type 'System.Data.SqlClient.SqlException' occurred in System.Data.dll

Additional information: Ocorreu um erro relacionado com a rede ou específico da instância ao estabelecer uma ligação ao SQL Server. O servidor não foi encontrado ou não estava acessível. Verifique que o nome da instância está correcto e que o SQL Server está configurado para permitir ligações remotas. (provider: Fornecedor de Pipes Nomeados, error: 40 - Não foi possível abrir uma ligação ao SQL Server)

Não sei se o erro está na Connection String ou no próprio Oracle

Share this post


Link to post
Share on other sites
Caça

LUISCASTRO-PC/SQLEXPRESS

Está instância existe?


Pedro Martins

Não respondo a duvidas por PM

Share this post


Link to post
Share on other sites
luiscastro

A instância existe sim.... o primeira linha comentada é o resultado quando adiciono a base dados ao visual studio...obtenho essa linha.....e copiei apenas a partir de data source

Share this post


Link to post
Share on other sites
Caça

Esse erro normalmente aparece quando o serviço não está a correr ou quando os protocolos de rede não estão activados, caso a instância esteja a funcionar em rede e não localmente.


Pedro Martins

Não respondo a duvidas por PM

Share this post


Link to post
Share on other sites
PutchPT

tens isto escrito na "connection string": Data Source=LUISCASTRO-PC/SQLEXPRESS

não tenho a certeza mas a barra não deveria estar virada para o outro lado? assim: Data Source=LUISCASTRO-PC\SQLEXPRESS...

neste site tens tudo sobre connections strings para várias bases de dados (muito util): http://www.connectionstrings.com/

e tenta também fazer uma coneccao com a base de dados o mais simples possivel (assim podes verificar se o problema vem ou não de configuracoes do servidor), do tipo:

"Data Source=LUISCASTRO-PC\SQLEXPRESS;AttachDbFilename=|DataDirectory|DB_Metereologia.mdf;Database=DB_Metereologia; Integrated Security=Yes;"

Onde é indicado o servidor com a BD, a directoria do ficheiro mdf, o nome da bd, e "ignorar segurancas" ou usar a seguranca do utilizador do pc... esta é a "forma" base que eu uso com connection strings para SQL Server e não tenho problemas tanto em web aplications como web services ou web sites...

espero ter ajudado... cumprimentos, PutchPT

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.