Jump to content
pedroazenham

Rede Linux não vê PCs

Recommended Posts

pedroazenham

Viva,

Tenho dois computadores com Ubuntu e um com Windows numa rede de casa.

Nos PCsLinux, clicando em locais e depois rede, não consigo visualizar nada... a única maneira de aceder aos outros computadores é através do Nautilus ou browser colocando smb://"ip_do_computador"

Que poderei eu fazer para visualizar os computadores no Nautilus sem ter de digitar o seu endereço ip?!?

Só consigo visualizar os PCs atravéz do PCWindows..

Cumprimentos e obrigada pela ajuda

Share this post


Link to post
Share on other sites
apocsantos

    Bom dia,

    Verifica se tens configurado correctamente o Samba. Pois provavelmente o que está a acontecer é que a maquina Linux não está no mesmo grupo de trabalho que as maquinas windows, ou não consegue traduzir nomes em IP's. Ambas as situações obrigam a que se reveja o ficheiro smb.conf .

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites
pedroazenham

Viva Apocsantos,

Obrigada pela ajuda.

As 3 máquinas estão exactamente no mesmo grupo de trabalho e os PCs com linux estão com IP fixo (para que duas impressoras de rede funcionem sempre direitinho...)

Penso que o problema terá a ver com os nomes dos PCs e a equivalência de IPs...

Podes dar-me alguma dica para que possa procurar informação acerca disso e resolver o meu problema... neste momento estou um pouco perdido!!!

Obrigada

Share this post


Link to post
Share on other sites
apocsantos

    Boa noite,

    Se estás a usar ip's fixos, edita o ficheiro /etc/hosts . Nesse ficheiro tens de ter o endereço ip da maquina e o nome que lhe corresponde. Deves ter um exemplo tipo:

192.168.1.1	mouse

    Neste exemplo quando é indicado o nome "mouse" ele tem a correspondência "192.168.1.1". Em pequenos grupos de trabalho isto funciona bem, mas em redes estruturadas maiores não, normalmente existe um servidor que é também controlador de domínio, servidor de dhcp e  servidor de dns.

    Provavelmente depois de gravares a alteração ao hosts tens de fazer na shell alguns comandos:

smbd stop
nmbd stop
smbd start
nmbd start

    Basicamente para pararem e re-iniciarem os serviços de suporte do Samba.

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites
pedroazenham

Viva Apocsantos,

Fiz o que me sugeriste e passo a indicar os passos dados:

Coloquei os IPs fixos nos 2 pcs Linux

PcB - IP:10.0.0.3 submask:255.255.255.0 Gatway:10.0.0.138

PcA - IP:10.0.0.4 submask:255.255.255.0 Gatway:10.0.0.138

Em ambos os Pcs consigo aceder á Net e ao outro pc com "smb://ip_do_pc"

Editei o ficheiro /etc/hosts e coloquei

127.0.0.1 localhost

10.0.0.3 PcB

10.0.0.4 PcA

Mesmo assim, não consigo visualizar os computadores de rede PcA e PcB em que ambos os sistemas são linux... embora comsiga aceder-lhes através de "smb://ip_do_pc"

Tens alguma ideia que me possa encaminhar no sentido certo???

Obrigada pela ajuda

Share this post


Link to post
Share on other sites
apocsantos

    Boa tarde,

    Se puderes indica a distribuição e versão da distribuição do GNU/Linux que estás a usar. Assim será mais fácil dar-te instruções especificas para a distribuição em causa ao invés de instruções "genéricas".

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites
pedroazenham

Viva Apocsantos,

Estou a usar em ambos os Pcs

Ubuntu 10.04 LTS (lucid)

Kernel Linux 2.6.32-31 generic

Gnome 2.30.2

Abraço

Share this post


Link to post
Share on other sites
apocsantos

      Boa noite,

    Confirma se tens o WINS activado no smb.conf

wins support = yes
browseable = true 

    E o hosts procura algo tipo isto:

#ip                #grupo trabalho     #nome_do_pc
192.168.1.1    workgroup           mousehouse

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites
pedroazenham

Viva Apocsantos,

Esta semana vou estar fora do escritório todos os dias, mas no próximo fim-de-semana vou investigar e testar os pontos que focaste!

Uma vez mais obrigada pela ajuda e depois comunicarei os resultados.

Obrigada

Pedro

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.