Jump to content
Sign in to follow this  
dipacheco

Inserir imagem em report

Recommended Posts

dipacheco

Boas pessoal! Mais uma vez reports... Quero inserir o logotipo da empresa que estiver a trabalhar com o programa e tnh um campo na BD q tem o caminho do logo no disco. Como faço para inserir uma imagem no report através do caminho que me é devolvido de um campo do dataset?

Share this post


Link to post
Share on other sites
Caça

Não sei se é possível carregar a imagem através de um caminho.

Essa imagem devia estar guardada na BD e depois seria mostrada no report através de uma PictureBox


Pedro Martins

Não respondo a duvidas por PM

Share this post


Link to post
Share on other sites
dipacheco

mas como guardo uma imagem na BD? eu sei q posso adicionar um campo image mas nao estou a fazer "inserção" entendes? estou a colocar os dados na tabela manualmente neste caso em especifico. Como coloco la uma imagem?

Share this post


Link to post
Share on other sites
dipacheco

acho q n m fiz entender... sorry! imagina q crio o campo image e dps quero inserir uma imagem atraves do management studio express. como o faço?

Share this post


Link to post
Share on other sites
dipacheco

serve perfeitamente, obrigado! mas fiquei com uma dúvida... aparece-me um "X" como se a imagem não existisse... será por ser PNG?

Share this post


Link to post
Share on other sites
dipacheco

nao é por aí que ja experimentei com jpg... fogo, q poderá ser? eu estou a usar o visual studio 2010 q é um bocadito diferente do q está em uso no tutorial. mas mesmo assim acho q fiz bem...

coloqui uma imagem e nas properties General->Source coloquei External.

E depois em baixo de external diz:

Use this image: e eu pus a expressa

=First(Fields!Logo.Value, "DataSet4")

Dentro desse campo Logo tenho o seguinte valor "C:\Users\Pacheco\Desktop\logos\LOGOJPG.jpg" sem aspas...

Alguem imagina o q poderá ser?

Share this post


Link to post
Share on other sites
dipacheco

isto d nem um tutorial saber seguir é complicado... lol

faltava-me "FILE://" & no campo value! :D Obrigado. TOPIC SOLVED! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.