Jump to content
Sign in to follow this  
tiago40812

Fontes mudam ao aceder atraves do IIS

Recommended Posts

tiago40812

Desenvolvi um Web Site que gera e imprime documentos em XPS, uso vários tipos de fontes para popular os documentos, incluindo códigos de barras (uma fonte dos CTT).

Ao publicar a aplicação e colaca-la no IIS do meu servidor, as fontes não saiem correctas na impressão mas os documentos são gerados correctamente. Alguem me sabe dizer porque???

Cumprimentos,

Tiago Vicente


Tiago Vicente

Share this post


Link to post
Share on other sites
M6

O IIS usa as fontes que tem disponíveis no sistema em que está a executar, verifica se o IIS tem acesso às fontes.


10 REM Generation 48K!
20 INPUT "URL:", A$
30 IF A$(1 TO 4) = "HTTP" THEN PRINT "400 Bad Request": GOTO 50
40 PRINT "404 Not Found"
50 PRINT "./M6 @ Portugal a Programar."

 

Share this post


Link to post
Share on other sites
tiago40812

Já instalei as fontes no servidor e ja pus o IIS_Users nas permissoes da pasta, continua a nao dar.

O que é estranho e que se eu for imprimir o ficheiro directamente, ele imprime correctamente.

Não posso perder tempo com isto, não consigo descobrir o porquê, vou criar um web service. É a maneira mais facil de contornar a situação.


Tiago Vicente

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.