Jump to content
rjsma

Apanhar o id atraves do nome de utilizador

Recommended Posts

Lfscoutinho

Boas,

Não tem a ver com o espaço, mas sim com a falta de aspas. Aliás quando usam essa "maneira" até devem de colocar sempre espaço para facilitar a leitura do código, por exemplo:

echo "<a href='perfil.php?id=" . $urlpriva['id_user'] . "'>" . $urlpriva['utilizador'] . "</a>";

No entanto, eu aconselho a quando usarem o modo da concatenação, em vez de aspas utilizarem plicas, ou seja:

echo '<a href="perfil.php?id=' . $urlpriva['id_user'] . '">' . $urlpriva['utilizador'] . '</a>';

E, quando usarem aspas utilizarem a sintaxe complexa, ou seja:

echo "<a href='perfil.php?id={$urlpriva['id_user']}'>{$urlpriva['utilizador']}</a>";

Editado !

Share this post


Link to post
Share on other sites
rjsma

Assim é como eu já tinha antes e já não estava a dar.Sequalhar é melhor mostrar o while completo para ter uma melhor noção do que tenho.


//Percorre os campos da tabela
while($urlpriva=mysql_fetch_array($sql)){
  echo "
  
  <table class='lista'>
  <tr >
    <td colspan=2 class=separador></td>
  </tr>  
  
  <tr>
  <td><br><a href='perfil.php?id='" . $urlpriva['id_user'] . "'>".$urlpriva['utilizador']."</a></td>
  </tr>
  <tr>
    <td><img src=".$urlpriva['favicon']."/> " .$urlpriva['nome'] . " </td>
      <td rowspan=3 align=center valign=middle><a href=comentarios.php?link=".$urlpriva['id'] ." target='blank'/><input type='submit' name='submit' value='Abrir'/></a></td></tr>
  <tr>
    <td>Categoria: " . $urlpriva['categoria'] . "</td>
      </tr>
  <tr>
    <td>Descrição: " . $urlpriva['descricao'] . "<br><br><br></td>
      </tr>
   <tr>
    <td>Data: " . $urlpriva['data'] . "<br><br><br></td>
      </tr>
</table>";
  
}

Share this post


Link to post
Share on other sites
blackangel

a tag <a> tem de ter aspas, os parametros passados no url é que nao,

ou seja o teu link tem de ficar

<a href="link.php?id=".$variavel."></a>

Share this post


Link to post
Share on other sites
Lfscoutinho

Boas,

Desculpa, eu tinha metido uma aspa a mais, mas já editei. E, aproveito para te dar mais uma dica: quando utilizares grandes blocos de texto, deves sair do modo de interpretação do PHP e utilizar a sintaxe alternativa para o código ficar mais legível. Por exemplo:

<?php
while($urlpriva=mysql_fetch_array($sql)) :
?>
<table class="lista">
	<tr>
		<td colspan="2" class="separador"></td>
	</tr>
	<tr>
		<td colspan="2"><br><a href="perfil.php?id=<?php echo $urlpriva['id_user'] ?>"><?php echo $urlpriva['utilizador'] ?></a></td>
	</tr>
	<tr>
		<td><img src="<?php echo $urlpriva['favicon'] ?>"/><?php echo $urlpriva['nome'] ?></td>
		<td rowspan="3" align="center" valign="middle">
			<a href="comentarios.php?link=<?php echo $urlpriva['id'] ?>" target="blank"/>
			<input type="submit" name="submit" value="Abrir" /></a>
		</td>
	</tr>
	<tr>
		<td>Categoria: <?php echo $urlpriva['categoria'] ?></td>
	</tr>
	<tr>
		<td>Descrição: <?php echo $urlpriva['descricao'] ?><br><br><br></td>
	</tr>
	<tr>
		<td>Data: <?php echo $urlpriva['data'] ?><br><br><br></td>
	</tr>
</table>
<?php
endwhile;
?>

Repara que também tinhas outros erros no html, como por exemplo a falta do colspan na segunda linha da tabela. E outros "erros" como falta de aspas e afins. Espero ter ajudado.

Share this post


Link to post
Share on other sites
Lfscoutinho

Boas,

<a href="link.php?id=".$variavel."></a>

O teu código está errado.

O correcto seria:

echo '<a href="link.php?id=' . $variavel . '">';

Share this post


Link to post
Share on other sites
rjsma

Boas,

Desculpa, eu tinha metido uma aspa a mais, mas já editei. E, aproveito para te dar mais uma dica: quando utilizares grandes blocos de texto, deves sair do modo de interpretação do PHP e utilizar a sintaxe alternativa para o código ficar mais legível. Por exemplo:

<?php
while($urlpriva=mysql_fetch_array($sql)) :
?>
<table class="lista">
	<tr>
		<td colspan="2" class="separador"></td>
	</tr>
	<tr>
		<td colspan="2"><br><a href="perfil.php?id=<?php echo $urlpriva['id_user'] ?>"><?php echo $urlpriva['utilizador'] ?></a></td>
	</tr>
	<tr>
		<td><img src="<?php echo $urlpriva['favicon'] ?>"/><?php echo $urlpriva['nome'] ?></td>
		<td rowspan="3" align="center" valign="middle">
			<a href="comentarios.php?link=<?php echo $urlpriva['id'] ?>" target="blank"/>
			<input type="submit" name="submit" value="Abrir" /></a>
		</td>
	</tr>
	<tr>
		<td>Categoria: <?php echo $urlpriva['categoria'] ?></td>
	</tr>
	<tr>
		<td>Descrição: <?php echo $urlpriva['descricao'] ?><br><br><br></td>
	</tr>
	<tr>
		<td>Data: <?php echo $urlpriva['data'] ?><br><br><br></td>
	</tr>
</table>
<?php
endwhile;
?>

Repara que também tinhas outros erros no html, como por exemplo a falta do colspan na segunda linha da tabela. E outros "erros" como falta de aspas e afins. Espero ter ajudado.

Lfscoutinho já deu . Apartir daqui já sei fazer o resto.

Obrigado aos dois  :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.