Jump to content
Ruben_Barbosa

VBA Excel 2007 criar celula vazia com formula

Recommended Posts

Ruben_Barbosa

Boa tarde pessoal.

Eu criei um Excel com umas macros onde me lista a informação e faz uns calculos com essa mesma informação.

So que o queria era nessa sheet nova que é criada com a macro e que lista a informação colocar uma celula vazia mas com uma formula.

Exemplo:

A1= vazio

Mas contem a formula de somar :)

A1= =SUM(B1+B2+B3)

eu ao preencher os valores na celulas b1 b2 e b3 ele aperecia me a o valor.

Fiz-me entender?

Abraço

Share this post


Link to post
Share on other sites
Andrepereira9

Boas    :)

Experimenta assim:

Range("a1").FormulaLocal = "=SOMA(B1:B3)"


A informática chegou para resolver problemas que antes não existiam

Quem ri por último é porque está conectado a 52 Kbs.

Share this post


Link to post
Share on other sites
Ruben_Barbosa

Andre Obrigado :) !!!!

Mas entretanto encontrei solução :) .

ActiveSheet.Cells(13, 11).Formula = "=K8*K9"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.