Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

amss1976

Referência absoluta das células

Recommended Posts

amss1976

Bom dia,

Estou com outro problema para resolver: o "$B$19". Se alguém me pudesse ajudar... :P

  • =SE(OU(G4="";$B$19=0);"";ARRED(G4/$B$19;2)) [nesta fórmula no "$B$19", o 19 estaria de pendente do n.º de linhas ocupadas e vai variar de ficheiro para ficheiro]

Se usar uma variável como String e a substituir na fórmula nos lugares correctos, ela funciona. No entanto, como o número da linha vai variar de ficheiro para ficheiro (embora dentro de cada ficheiro seja fixa nas várias linhas), tenho de:

a) definir o tipo de variável a usar

(já tentei usar o código seguinte):

Dim Rng1 As Range
Set Rng1 = Range(Cells(10, 1))
Cells(Row, Col).FormulaLocal = "=SE(OU(G4="""";" & Rng1 & "="""");"""";ARRED(F4/" & Rng1 & ";2))"

mas dá-me o erro 1004

b) fixar a linha - ainda não encontrei solução... :(

Consegui resolver o problema assim:

Dim mg As String
Cells(1, 1).Offset(Nartigos + 3, 1).Select
mg = ActiveCell.Address
Cells(Row, Col).FormulaLocal = "=SE(OU(G4="""";" & mg & "="""");"""";ARRED(F4/" & mg & ";2))"

Esta foi a solução que encontrei. Acham que há alguma forma mais simples para este problema?

Obrigado desde já pela ajuda.

Share this post


Link to post
Share on other sites
jpaulino

Tirando o facto de não precisares de seleccionar a célula, também não estou a ver uma solução.

Dim mg As String

mg = Cells(1, 1).Offset(Nartigos + 3, 1).Address

Cells(Row, Col).FormulaLocal = "=SE(OU(G4="""";" & mg & "="""");"""";ARRED(F4/" & mg & ";2))"

Share this post


Link to post
Share on other sites
amss1976

Tirando o facto de não precisares de seleccionar a célula, também não estou a ver uma solução.

Dim mg As String

mg = Cells(1, 1).Offset(Nartigos + 3, 1).Address

Cells(Row, Col).FormulaLocal = "=SE(OU(G4="""";" & mg & "="""");"""";ARRED(F4/" & mg & ";2))"

Obrigado pela dica.  :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.