Jump to content
sergiosilva

Fazer aparecer imagem através da função SE ... em excel

Recommended Posts

sergiosilva

Olá quero fazer aparecer uma imagem numa célula do excel através da resposta inserida em outra célula.

1)Por exemplo quando escrevo sergio na célula A1 quero que em A2 ou num intervalo de A2 até A4 apareça a foto do sergio através do comando =SE(A1="sergio";imagem sergio.jpeg;"erro"). Se em A1 não estiver sergio, então aparecerá "erro".  A parte que está a bold é que não percebo. Como é que faço referência a uma imagem, numa fórmula??

2)Se der para fazer referência ao ficheiro jpeg, depois tenho de gravar sempre esse ficheiro juntamente com o do excel, sempre que quiser transferir o ficheiro excel para outro computador? Ou posso exibir a imagem numa parte da folha de excel e na fórmula não fazer ligação ao ficheiro jpeg mas sim á imagem que está na folha? É que assim a imagem estaria sempre presente numa parte da folha e não precisava de andar a copiar todos os ficheiro jpeg juntamente com o ficheiro excel.

Share this post


Link to post
Share on other sites
dlemos

Bom dia

Tenta:

Para a pergunta 1:


if sheets("nomeSheet").range("A1").value="sergio" then
sheets("nomeSheet").Pictures.Insert("C:\imagem.jpeg")
end if 

if sheets("nomeSheet").range("A1").value<>"sergio" then
sheets("nomeSheet").Range("A2:A4").value="ERRO"
end if 

Para a pergunta 2:

Podes por exemplo guardar a imagem numa outra sheet, e quando quiseres que apareça na sheet1 (por exemplo) fazes copyPaste da imagem, que para efeitos de Office, é uma "shape"

Share this post


Link to post
Share on other sites
sergiosilva

Olá a solução do Dlemos não consegui fazer porque n entendo nada de Vbasic. Sei que é só copiar o que escreveste e atribuir os nomes das sheets e imagens, mas e depois? O que faço nas células de excel?

A solução do PauloSemblano também não conseguir fazer apesar de parecer simples. Ho Paulo consultei os teus 2 links mas mesmo assim não consegui. Será que conheces um link no youtube?

Share this post


Link to post
Share on other sites
sergiosilva

Olá eu vi o eu exemplo Paulo mas não consegui fazer porque não entendi "Usando o recurso Definir Nome:

Clique em Inserir/Nome/Definir" (Acho que você usa termos brasileiros e o meu excel está português portugal) . De qualquer forma encontrei no youtube como fazer, mas está em inglês e parece a mesma solução que você utiliza. Mas o sujeito utiliza uma fórmula VLOOKUP e eu não entendo qual é o nome da fórmula em português portugal. Isto deve ser mesmo simples... sou mesmo tótó  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.