Jump to content
Phill_88

abrir ficheiro haskell no terminal

Recommended Posts

Phill_88

Boas,ppl

eu comprei o mac depois de instalar ghci e o aquamacs, mas nao consigo abrir o ficheiro no terminal para compilar, por exemplo, gravei o ficheiro na "secretaria" que é o equivalente ao ambiente de trabalho no windows, mas depois nao consigo abrir o ficheiro que quero para complicar

O caminho que faço é o seguinte

1º gravar o ficheiro do aquamacs em .hs.

2º abrir o terminal

3º ghci

4º :l haskell.hs

mas dame o ficheiro nao carregado, como faço para ele funcionar?

Crumps

Share this post


Link to post
Share on other sites
jpedro20

Que erro é que te dá?

EDIT: Se gravas o ficheiro no Desktop primeiro tens de fazer no terminal

cd Desktop

e so depois fazes ghci ficheiro.hs

Share this post


Link to post
Share on other sites
Phill_88

new-host:~ filipesarocha$ :l haskell.hs

-bash: :l: command not found

new-host:~ filipesarocha$

isto é o q me parece no terminal

Share this post


Link to post
Share on other sites
Baderous

O comando :l é um comando do GHCi e não do terminal. Tens de entrar primeiro no GHCi e só depois é que invocas esse comando.

Share this post


Link to post
Share on other sites
jpedro20

Isto é o que deves fazer:

new-host:~ filipesarocha$ cd Desktop   #mudar para a directoria em que tens o ficheiro .hs (neste caso para Desktop)
new-host:~ filipesarocha$ ghci ficheiro.hs

ou

new-host:~ filipesarocha$ cd Desktop   #mudar para a directoria em que tens o ficheiro .hs (neste caso para Desktop)
new-host:~ filipesarocha$ ghci
...
Prelude>:l ficheiro.hs

Share this post


Link to post
Share on other sites
Phill_88

Bem fiz o q o jpedro disse para fazer, mas deume novo erro, de mais lembro que o meu mac ta em portugues nao sei se mudará alguma coisa como em vez desktop ter de colocar secretaria, mas fazendo desktop deume agora novo erro

Last login: Thu Jan  6 20:07:16 on ttys000

new-host-2:~ filipesarocha$  cd desktop

new-host-2:desktop filipesarocha$ ghci

GHCi, version 6.12.3: http://www.haskell.org/ghc/  :? for help

Loading package ghc-prim ... linking ... done.

Loading package integer-gmp ... linking ... done.

Loading package base ... linking ... done.

Loading package ffi-1.0 ... linking ... done.

Prelude> :l haskell.hs

[1 of 1] Compiling Main            ( haskell.hs, interpreted )

haskell.hs:1:0: Invalid type signature

Failed, modules loaded: none.

Prelude>

será que é isto que deve aparecer se tiver alguma coisa errada?

estranho porque na faculdade davame uma coisa diferente

Share this post


Link to post
Share on other sites
Baderous

Um conselho que te dou é que não uses SOs em PT para desenvolvimento. Já tive muitas dores de cabeça à pala disso.

No teu caso parece-me é que o erro é no código do ficheiro haskell.hs.

Share this post


Link to post
Share on other sites
jpedro20

Um conselho que te dou é que não uses SOs em PT para desenvolvimento. Já tive muitas dores de cabeça à pala disso.

No teu caso parece-me é que o erro é no código do ficheiro haskell.hs.

Concordo com o Baderous. Usei uma vez ubuntu em pt e jurei para nunca mais.

Quanto ao erro parece ser mesmo no código

haskell.hs:1:0: Invalid type signature

na função tens um tipo inválido. Coloca o código se quiseres para ver onde está o erro.

ah,nao percebi o nao utilizar o SO em pt?

como assim?

em vez de ter o SO em português, colocá-lo em inglês

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.