Jump to content
Sign in to follow this  
Matunga

Rodape dentro da div conteudo - Porquê? [RESOLVIDO]

Recommended Posts

Matunga

Bom dia, estou com imensos problemas em conseguir que nas paginas com informação maior em php, o rodapé não me vá para a div conteúdo.

Segue abaixo a extrutura simplificada da minha página:

index.php

<?
<div id="tudo">

   <div id="banner_topo">
   </div><!-- banner_topo -->

   <div id="menu">
   </div><!-- menu -->

   <div id="conteudo">
   </div><!-- conteudo -->

   <div id="rodape">
  </div><!-- rodape -->

       
</div><!-- tudo -->

?>

Depois tenho o arquivo do CSS onde coloco o banner_topo, rodape, o fundo do menu etc ...

Seguem em baixo as imagens para comprovar:

1. Página correctamente apresentada:

paginacorrecta.png

2. Rodapé no interior da div conteúdo:

width=750 height=362http://img824.imageshack.us/img824/9337/rodapenadivconteudo.png[/img]

Expliquem-me o porquê de tendo a página a mesma estrutura, aparece mal em certas páginas e em outras aparece bem?

Obrigado :P

Usa as tags 'code' para formatar o código, de forma a todos terem uma leitura mais fácil do mesmo - Caya

Share this post


Link to post
Share on other sites
Matunga

Segue o CSS que estou a usar:


<style type="text/css">

body {margin:0; padding:0; background: url(imagens/geral/imagem_fundo.jpg);
text-align:center; 

#tudo {background-color: #FFFFFF; border: 2px solid red; padding: 5; width: 1000px; margin:0 auto;
text-align:left; 

#topo { height: 150; margin: 0 auto;  width: 1000; background-color: #eee; border: 0px solid red; background:  url(imagens/geral/banner_topo.jpg); }

#menu { height: 41; margin: 0 auto; width: 1000; background-color: #eee; border: 0px solid red; background: url(imagens/geral/menu.jpg);}

#conteudo { text-align: justify; padding:10; overflow: auto; height: 420; margin: 0 auto; width: 980; background-color: #eee; border: 0px solid red;  }

#titulo_pagina {font-variant: small-caps; font-weight: bold; text-align: center; height: 30; width: 750; background: url(imagens/geral/fundo_titulo_pg.jpg);
margin: 0 auto;}

#rodape { height: 150; margin: 0 auto; width: 1000; background-color: #eee; border: 0px solid red; background: url(imagens/geral/banner_rodape.jpg);}

Ja dei voltas e mais voltas e nada, alguma solução?

Usa as tags 'code' para formatar o código, de forma a todos terem uma leitura mais fácil do mesmo - Caya

Share this post


Link to post
Share on other sites
Caya

Para já, sempre que o valor não seja 0, tens de especificar o unidade. Estás a fazer o contrário.

Depois não estás a fechar nem o body nem o #tudo.

Antes de mais nada, experimenta assim e diz se há progressos:

body {margin:0; padding:0; background: url(imagens/geral/imagem_fundo.jpg);
text-align:center;height:100%}

#tudo {background-color: #FFFFFF; border: 2px solid red; padding: 5px; width: 1000px; margin:0 auto;
text-align:left;}

#topo { height: 150px; margin: 0 auto;  width: 1000px; background-color: #eee; border: 0 solid red; background:  url(imagens/geral/banner_topo.jpg); }

#menu { height: 41px; margin: 0 auto; width: 1000px; background-color: #eee; border: 0 solid red; background: url(imagens/geral/menu.jpg);}

#conteudo { text-align: justify; padding:10px; overflow: auto; height: 420px; margin: 0 auto; width: 980px; background-color: #eee; border: 0 solid red;  }

#titulo_pagina {font-variant: small-caps; font-weight: bold; text-align: center; height: 30; width: 750; background: url(imagens/geral/fundo_titulo_pg.jpg);
margin: 0 auto;}

#rodape { height: 150px; margin: 0 auto; width: 1000px; background-color: #eee; border: 0 solid red; background: url(imagens/geral/banner_rodape.jpg);}

Share this post


Link to post
Share on other sites
Matunga

sim, de facto resultou, perfeitamente bem agora, ajustando agora um pouco o rodape fica a 100%

obrigado pela ajuda :P

Share this post


Link to post
Share on other sites
Caya

Great.

Sempre que acontecer comportamentos estranhos começar por verificar se o código está todo bem, por exemplo, faltas de ';', falta de unidades (px, %, ...), '{' fechadas, etc... Muitas vezes o problema está ai.  :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.