Jump to content

Placa de Rede Wireless PCI - Linux w/ Internet Part2!


UnKnowN
 Share

Recommended Posts

bem entao o que se passa é o seguinte:

Arranjaram-me uma Placa de Rede Wireless PCI para eu ver se dava para por net no meu querido linux ( :down:).

De inicio achei que estava tudo bem, no CD das drivers vinha lá uma pastinha a dizr Linux, quando entrei apareciam-me outras duas pastas: RedHat7.3 e RedHat9.0 .

Bem, eu fiquei à nora e entao fui falar com um amigo meu para ver se conseguia resolver o problema... que nesta caso seria "qual é a pasta" e após isso, como compilar uma data de files dentro da respectiva pasta, pois estas traziam um file que dizia "MakeFile" e uma data de outros ficheiros, entre eles uns *.c, *.h, e outros de que nao me recordo.

Este meu amigo disse-me para eu navegar (pela consola) até à pasta (que tinha copiado do CD para o meu Desktop) e disse-me para eu escrever na consola "./configure", eu disse que dava erro, e ele disse para eu escrever "make". Depois deste "make" nao funcionar também... ele disse-me que nao sabia o que me dizer... apenas me disse que como aquilo nao dava nao conseguiria pôr as drivers a "trabalhar"...e assim eu teria de comprar outra Placa de Rede ...

Por mim próprio ainda tentei escrever na consola "makefile" ao invés de "make" ou "./configure" mas nao resultou  ?

O que é que faço ? Alguma sugestão ? Compilar a kernel (nem sei bem o que isto é  :wallbash:) ?

Estou a entrar num clima de frustração TERRIVELLL  ? ?

Link to comment
Share on other sites

Pois... calma meu amigo :)

Primeiro que tudo anota qual é o erro que te dá... e porquê? Provavelmente falta-te uma lib 😄

Já agora diz qual é a tua distro e a tua placa wireless 😄

Link to comment
Share on other sites

vbmaster, pode ser simples mas não vamos compilar o kernel por tudo e por nada :)

Em principio o kernel já vem configurado para o wireless por isso devem ser problemas de libs em falta 😄

Link to comment
Share on other sites

Distribuição: Ubuntu Dapper Drake (6.06 penso)

Placa de Rede Wireless PCI Micronet Modelo No. SP906BB

Os erros eram:

em "./configure" - Arquivo ou Directório nao encontrado.

em "make" - command not found

em "makefile" (que provavelmente nem existe esta função) - command not found

Link to comment
Share on other sites

"arquivo ou Directorio não encontrado" --> tens a certeza k lá existe o configure? :S

"make" command not found -> faz: sudo apt-get install build-essential

Link to comment
Share on other sites

"arquivo ou Directorio não encontrado" --> tens a certeza k lá existe o configure? :S

"make" command not found -> faz: sudo apt-get install build-essential

1º-Não, não existe ... lol! mas foi o que me disseram para fazer, como nao percebo anda de Linux :|

2º-Faço sudo com o CD do Ubuntu na drive certo? é que nao tenho net :|

Obrigado a todos até agora :)

Link to comment
Share on other sites

Acho que já houve uma luzinha lá ao fundo, lol... se calhar nao é nada, mas o make já funciona, obrigadão _JR_, o problema é que depois de navegar até à pasta do RedHat9.0 e fazer make, dá uma data de erros, uma data de "gatafunhos" lol^^ (nao percebo nada daquilo) só sei que o último erro é:

make : ** [r8180_pci_init.o] Erro 1
Link to comment
Share on other sites

Acho que já houve uma luzinha lá ao fundo, lol... se calhar nao é nada, mas o make já funciona, obrigadão _JR_, o problema é que depois de navegar até à pasta do RedHat9.0 e fazer make, dá uma data de erros, uma data de "gatafunhos" lol^^ (nao percebo nada daquilo) só sei que o último erro é:

make : ** [r8180_pci_init.o] Erro 1

Esse não diz qual é o erro... talvez numas linhas acima, não muito longe diga de facto qual foi o erro...

Link to comment
Share on other sites

Acho que já houve uma luzinha lá ao fundo, lol... se calhar nao é nada, mas o make já funciona, obrigadão _JR_, o problema é que depois de navegar até à pasta do RedHat9.0 e fazer make, dá uma data de erros, uma data de "gatafunhos" lol^^ (nao percebo nada daquilo) só sei que o último erro é:

make : ** [r8180_pci_init.o] Erro 1

Esse não diz qual é o erro... talvez numas linhas acima, não muito longe diga de facto qual foi o erro...

Pah dá mm bue erros, que é que achas de postar aqui o 'code' todo ?

O prob é que ao passar de Linux apra Win o texto fica td fdd pk a codificação é diferente :|

Os que têm linux vêm bem... mas que é que acham ?

Link to comment
Share on other sites

Ah um sítio particular da compilação, acima desse que deverá dizer qual foi o erro...

Essa deve ser uma mensagem final a dizer que a compilação acabaou com um erro...

Mas fizeste antes o .configure right?

Link to comment
Share on other sites

Ah um sítio particular da compilação, acima desse que deverá dizer qual foi o erro...

Essa deve ser uma mensagem final a dizer que a compilação acabaou com um erro...

Mas fizeste antes o .configure right?

LoL nao :|

vou tentar ja digo qq coisa

Link to comment
Share on other sites

Tens a certeza que isso que estás a querer instalar é por compilação?

Já experimentaste ler o readme ou o install (ficheiro de texto que normalmente vêm)...

lol, :rtfm: :)

Link to comment
Share on other sites

Tens a certeza que isso que estás a querer instalar é por compilação?

Já experimentaste ler o readme ou o install (ficheiro de texto que normalmente vêm)...

lol, :rtfm: 😄

pah eu tou a guiar-me pelo que o meu outro amigo me disse... fazia "./configure", como nao deu, disse.me para fazer "make"

PS: o ./config antes do make nao deu... dá o mesmo erro "arquivo ou directorio nao encontrado" ...vou ler o readme  e tentar for my own :)

Mesmo assim continuem a dar sugestoes 😄

Link to comment
Share on other sites

Não te serve de nada afzer make sem fazer ./configure.

Mas se não dá :|

Já tentei seguir as instruçoes de "<instalation>" no readme.

Na parte inicial aquilo diz apra eu fazer:

gcc -v

Tudo bem, mas depois dizia lá:

if gcc version is 2.xx use driver blablabla.zip e na pasta nao ha nada .ZIP

if gcc version is 3.xx use driver blablabla.zip e na pasta nao ha nada .ZIP

MAS A MINHA É 4.XX :|

Nada me corre Bem LOL xD

Vou tentar postar aqui o readme file todo para ver se me conseguem ajudar :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.