Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

dicas3d

Fóruns de visualg (http://pt.wikipedia.org/wiki/Visualg).

Mensagens Recomendadas

dicas3d

:biggrin:

Olá pessoal.

Conheci hoje um programa chamado visualg que permite testar algoritmos escritos em português estruturado.

Para quem não o conhece, este programa permite alem de testar converter o algoritmo para pascal, entre outras coisas e tem informações no link que está no titulo mas basta clicar aqui.

Qual o melhor fórum sobre este programa?


Abraços

dicas3d

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
dicas3d

Cá está um código do visualg:

algoritmo "Conversão Celsiu farnheneit"
var opcao, celsius, farnheit : real
inicio
Escreval("Introduz o numero a converter seguido do numero da medida")
Escreval("         1 para converter celsius para farnheneit")
Escreval("         2 para converter farnheneit para celsius")
leia(celsius, opcao)
farnheit <- celsius
se opcao = 1 entao
farnheit <- celsius * 1.8 + 32
Escreval(celsius, "º Celsius são ",farnheit , "º Fahrenheit")
senao
celsius <- (farnheit - 32) / 1.8
Escreval(farnheit, "º Fahrenheit são ", celsius, "º Celsius")
fimse
fimalgoritmo


Abraços

dicas3d

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
Quadrado

Muito fixe..... :thumbsup: Não conhecia mas estou a adorar, e parece ser muito fácil....


Será? Porquê? O quê?   - Estudar Sempre -

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
dicas3d

Vou pedir aos moderadores que mudem o titulo do tópico, para ter mais informações para:

"Visualg(o que é, fóruns e sites(http://pt.wikipedia.org/wiki/Visualg).)". e tambem para criarem uma nova opção no geshi chamada pseudocódigo, que é como chamam a estes textos contendo os passos de um programa já que tambem tem regras com uma linguagem de programação normal.

Aproveito e deixo aqui uma imagem dos menus com pseudocódigo acima.

menusvisualg.png


Abraços

dicas3d

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.