Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

dicas3d

Fóruns de visualg (http://pt.wikipedia.org/wiki/Visualg).

Recommended Posts

dicas3d

:cheesygrin:

Olá pessoal.

Conheci hoje um programa chamado visualg que permite testar algoritmos escritos em português estruturado.

Para quem não o conhece, este programa permite alem de testar converter o algoritmo para pascal, entre outras coisas e tem informações no link que está no titulo mas basta clicar aqui.

Qual o melhor fórum sobre este programa?


Abraços

dicas3d

Share this post


Link to post
Share on other sites
Quadrado

Uma coisa ao clicar ai não liga para site nenhum... :D


Será? Porquê? O quê?   - Estudar Sempre -

Share this post


Link to post
Share on other sites
dicas3d

Cá está um código do visualg:

algoritmo "Conversão Celsiu farnheneit"
var opcao, celsius, farnheit : real
inicio
Escreval("Introduz o numero a converter seguido do numero da medida")
Escreval("         1 para converter celsius para farnheneit")
Escreval("         2 para converter farnheneit para celsius")
leia(celsius, opcao)
farnheit <- celsius
se opcao = 1 entao
farnheit <- celsius * 1.8 + 32
Escreval(celsius, "º Celsius são ",farnheit , "º Fahrenheit")
senao
celsius <- (farnheit - 32) / 1.8
Escreval(farnheit, "º Fahrenheit são ", celsius, "º Celsius")
fimse
fimalgoritmo


Abraços

dicas3d

Share this post


Link to post
Share on other sites
Quadrado

Muito fixe..... :thumbsup: Não conhecia mas estou a adorar, e parece ser muito fácil....


Será? Porquê? O quê?   - Estudar Sempre -

Share this post


Link to post
Share on other sites
dicas3d

Vou pedir aos moderadores que mudem o titulo do tópico, para ter mais informações para:

"Visualg(o que é, fóruns e sites(http://pt.wikipedia.org/wiki/Visualg).)". e tambem para criarem uma nova opção no geshi chamada pseudocódigo, que é como chamam a estes textos contendo os passos de um programa já que tambem tem regras com uma linguagem de programação normal.

Aproveito e deixo aqui uma imagem dos menus com pseudocódigo acima.

menusvisualg.png


Abraços

dicas3d

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.