Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

Sign in to follow this  
A_T_C

Recuperar ubuntu

Recommended Posts

A_T_C

Boa tarde!

Quando estava aceder ao ubuntu através do wubi, surgiu uma linha de comandos grub e não sei o que fazer para poder recuperar os documentos que la tinha guardados. Já tentei chkdsk /r no windows mas diz que não tenho permissões! :) :wallbash:

Alguém pode ajudar?? :down:

Share this post


Link to post
Share on other sites
Palmeira

Boas, claro que ajudamos :)

Essa linha de comandos (ficas já a saber que é do GRUB - Bootloader usado pelo ubuntu) aparece-te sempre que instalas o Ubuntu pelo WUBI ou quando já tens instalado e fazes update ao sistema ?? eu tive esse problema, mas era sempre que fazia update ao kernel, o grub estourava, mas qualquer coisa como escrever : grub 2 fix na consola do grub recuperava-me o sistema. não tentes isto ainda, não consigo confirmar e já é um pouco tarde pra ir googlar, mas esse problema até está documentado como bug do wubi...

Se puderes, instala o ubuntu numa partiçao própria, e não dentro do windows.

PS : logo que apure quais os comandos pra recuperares o sistema, posto aqui :D

Cumps,

EDIT :  :thumbsup: é isto :

Re: GRUB looks like not finding Ubuntu

This was common problem with wubi few months ago but it should have been gone by now. I'm not expert in wubi but you could start it with these commands:

sh:grub>set root=(loop0)

sh:grub>linux /boot/vmlinuz-2.6.31-14-generic root=/dev/sda1 loop=/ubuntu/disks/root.disk ro

sh:grub>initrd /boot/initrd.img-2.6.31-14-generic

sh:grub>boot

You should use /dev/sda1 only if your ubuntu folder is on the first partition on the first disk (be careful, even if it is on C: you could have another small recovery partition before C: and C: can be /dev/sda2 in ubuntu terms).

So if you need to use something else instead of /dev/sda1, change it. You can also look at your partitions by booting windows and in disk management (windows button + R, type diskmgmt.msc, hit Enter).

After you have booted into wubi, in terminal do:

sudo update-grub2

As far as I know (because I don't use wubi), that should fix it.

And long term, why don't you suggest runing proper full ubuntu, on it's own partition and filesystem, and not wubi which is only virtual ubuntu. That's why you are seeing windows bootloader first, and then "grub2". There is no way to avoid that. In fact that is not grub2, you don't have grub2, that's only virtual grub2.

 

substituis o que está a negrito :

sh:grub>linux /boot/vmlinuz-2.6.31-14-generic root=/dev/sda1 loop=/ubuntu/disks/root.disk ro

sh:grub>initrd /boot/initrd.img-2.6.31-14-generic ; pela versão correspondente ao kernel para o qual fizeste upgrade, ou seja tinhas o 2.6.31-14, mas instalas-te o 2.8.60-12-generic, metes este último :D ; também deves conseguir ver a partição em C:\wubi ou coisa do género ou nem por isso ?

posta original no ubuntuforums : http://ubuntuforums.org/showthread.php?t=1391670

Cumps

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.