Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

anagrama

Upgrade do Ubuntu - problemas

Mensagens Recomendadas

anagrama

Bom-dia

Vou expôr uma questão que se alguém me conseguir dar uma pista para retomar o que tinha agradecia.

Tenho um computador com 2 discos de igual capacidade. Num, tenho instalado em duas partições diferentes o windows 7 e na outra o windows server 2008; o segundo, está só destinado para o Ubuntu, que criou mais umas partições  durante a sua instalação. Arranco o computador e faço a selecção dos discos via tecla F8. No 1º disco , o dual boot conduz-me a optar pelo Windows 7 ou pelo windows server; no 2º disco, aparecem-me algumas opções para o Ubuntu, da qual a que está por defeito, permite arrancar normalmente o Linux Ubuntu. Tudo funcionou bem, ate que , decidi efectuar a actualização do Ubuntu para a nova release, creio que ainda em teste.

Ao arrancar agora o computador via tecla F8 e optando por qualquer um dos discos, aparece-me sempre o mesmo menu do Ubuntu, tendo acrescentado uma opção do Windows 7 Loader (on dev/sda 1). Ou seja, independente de seleccionar um dos discos, o écran de arranque é sempre o mesmo, tendo acrescentado, na última linha, amensagem acima realçada, que não permite o arranque.

Há alguma maneira rápida de resolver a questão?

Cumprimentos

Anagrama

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
anagrama

olá

Penso que o meu problema foi não ter desligado o 1º disco e por consequência o Linux andou a criar o sistema de ficheiros não sei bem por onde... é o que faz estar a fazer várias coisas ao mesmo tempo.

Gostaria de saber se tinha uma solução simples ou terá que ser radical...

Em resumo: tenho dois discos: um com o windows 7 + o windows server; outro com Linux (Ubuntu). Fiz a nova atualização do Ubuntu e o sistema inicial de escolha, no arranque no 1º disco desapareceu e passou a ser igual ao do segundo. Ou seja, indpendentemente da escolha de um dos discos, a opção de arranque é sem pre a mesma (Linux/Ubuntu) tendo sido acrescentada a opção Windows 7 Loader (que não arranca).

Há alguma solução rápida?

Anagrama

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
Cynary

Quando fizeste o update, o grub deve ter-se instalado no MBR dos dois discos, usando a informação de boot do disco com Linux.

Acho estranho que a opção Windows 7 Loader não funcione. Mas tenho uma forma rápida de resolveres isso:

Primeiro, apagar as opções extra do windows: desliga o disco com o windows, entre no linux e faz o seguinte comando:

sudo update-grub

Depois, tens de desligar o disco com o linux, colocar o CD de recuperação do windows 7, e escrever estes comandos:

bootrec.exe /fixboot
bootrec.exe /fixmbr

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.