Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

Sign in to follow this  
sagostinho

célula com valores variaveis

Recommended Posts

sagostinho

ola estou a a fazer uma folha de calculo e estou com o seguinte problema que não consigo resolver  pois ainda não percebo muito de excel então é o seguinte a célula a1 tem valores que variam entre -6 e 6 e o que eu queria fazer era o seguinte na celula a2. se a celual A1 fosse maior ou igual (-0,1) então a A2 era (0) entre (-0,2 e -1,5) então a A2 dava (1) entre (-1,6 e -3) a A2 dava 3 e se fosse maior que 3  a A2 dava (4). obrigado

Share this post


Link to post
Share on other sites
jmaocubo

ola estou a a fazer uma folha de calculo e estou com o seguinte problema que não consigo resolver  pois ainda não percebo muito de excel então é o seguinte a célula a1 tem valores que variam entre -6 e 6 e o que eu queria fazer era o seguinte na celula a2. se a celual A1 fosse maior ou igual (-0,1) então a A2 era (0) entre (-0,2 e -1,5) então a A2 dava (1) entre (-1,6 e -3) a A2 dava 3 e se fosse maior que 3  a A2 dava (4). obrigado

Olá

Ou seja, o que pretendes é:

A1>= -0.1 até 3 (inclusivé) dá 0

A1 entre -1.5 e -0.2 dá 1

A1 entre -3 e -1.6 dá 3

A1 > 3 dá 4

Usa esta fórmula na célula A2:

=SE(A1;SE(E(A1>=-0,1;A1<=3);0;SE(A1>3;4;SE(E(A1>=-3;A1<=-1,6);3;SE(E(A1>=-1,5;A1<=-0,2);1))));"")

Ou esta no caso de quereres mesmo restringir ao intervalo de -6 a 6 :

=SE(A1;SE(E(A1>=-0,1;A1<=3);0;SE(E(A1>3;A1<=6);4;SE(E(A1>=-3;A1<=-1,6);3;SE(E(A1>=-1,5;A1<=-0,2);1))));SE(E(A1<-6;A1>6);"";""))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.