Jump to content

ligação wamp - php


chocolate
 Share

Recommended Posts

Boas,

Instalei o wampserver mas não consigo correr nada com código  PHP porque me aparece a mensagem de "não ligação ao localhost". Quando verifico, é-me pedida uma password.

exemplo:

<?php

$x = 2;

echo $x;

?>

o ficheiro anterior (algarismo.php) é guardado na pasta wamp/www e ao realizar o http://localhost/algarismo.php vem-me a indicação que não é permitida a ligação. Activo o localhost e aparece: a ligar a <nome> e, depois, duas caixas de texto. a primeira com o nome do utilizador: <nome> e a segunda a pedir a palavra-passe e uma caixa de texto em branco. Que palavra-passe? Como ultrapasso isto?

Cumprimentos,

João Moreira

Link to comment
Share on other sites

Provavelmente tens o IIS à escuta na mesma porta... Qual é o SO com que estás a trabalhar?

"Nós somos o que fazemos repetidamente, a excelência não é um feito, e sim, um hábito."
Não respondo a questões por PM que possam ser colocadas no fórum!

Link to comment
Share on other sites

A mensagem que dá é esta:

Este erro (HTTP 404 Não Encontrado) significa que o Internet Explorer conseguiu ligar ao Web site, mas a página que pretendia não foi localizada. É possível que a página Web esteja temporariamente indisponível. Em alternativa, o Web site poderá ter sido alterado ou a página Web poderá ter sido removida.

Para mais informações sobre erros HTTP, consulte a Ajuda.

Soluções?

chocolate

Link to comment
Share on other sites

Boas,

continuo com o mesmo problema. Algumas questões:

1 - O Wamp possui alguma restrição quanto ao processo de introdução do código PHP no HTML ? (Exemplo: <? php... ?> ou <script language="php">...</script)

2 - É possível ter sido alterada alguma linha do php.ini, quando da instalação ?

chocolate

Link to comment
Share on other sites

As tags <? php... ?> são as que limitam o código PHP. Se não estou em erro, o Wamp não executa por defeito em ficheiros .html

E estas tags não existem.

<script language="php">...</script

PS: Não respondo a perguntas por mensagem que podem ser respondidas no fórum.

Link to comment
Share on other sites

não, tem que estar na extensão .php

se usas o bloco de notas ao gravar fazes "Guardar com o tipo: Todos os ficheiros" e no nome do ficheiro que queres adicionas no fim .php, senão vai ficar index.php.txt, e o wamp e o próprio computador interpreta sendo um ficheiro .txt

...Join the dark side...and get a free cookie...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.