Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

Sign in to follow this  
charlie69

Userform em branco enquanto corre macro

Recommended Posts

charlie69

Boas malta

Estou com um problema.

Ao executar uma macro ele chama uma form que diz: "Aguarde"... enquanto corre o resto da macro. O problema é que o form surge em branco, não mostrando o que está lá escrito.

Como fazer com que isso não se passe:

já tentei com o

userform_initialize

me.repaint

DoEvents

end

mas continua sem dar.

Cumps

Share this post


Link to post
Share on other sites
jmaocubo

Olá

dá para fazeres um printscreen quando está a executar a macro?

Essa userform aparece com os contornos ? é que pode ser excesso de informação ao mesmo tempo e o pc está a dar prioridade á macro (mais ou menos isto).

Uma sugestão:

poderias criar uma msgbox que diria "Vai ser agora executado o cálculo xpto. Por favor clique em OK e aguarde"

depois colocavas todo o teu código e no final antes do "end sub" colocavas nova msgbox que diria "Calculo finalizado."

cumps,

Miguel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.