Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

Sign in to follow this  
rjsma

[RESOLVIDO]memoria insuficiente no resources

Recommended Posts

rjsma

boas

Numa aplicação adicionei 4 ficheiros de audio nos resources, e agora ao executar a aplicação da-me um erro dizendo que não existe memoria suficiente para concluir a operação.Alguem sabe como posso resolver isto?não existe uma maneira de aumantar a memoria ou uma coisa assim?

abraço

Share this post


Link to post
Share on other sites
jpaulino

Reinicia o Serviço do IIS.

O que é que o IIS tem a ver com a memória?

Numa aplicação adicionei 4 ficheiros de audio nos resources, e agora ao executar a aplicação da-me um erro dizendo que não existe memoria suficiente para concluir a operação.Alguem sabe como posso resolver isto?não existe uma maneira de aumantar a memoria ou uma coisa assim?

Ficheiros grandes não devem ser colocado nos resources

Share this post


Link to post
Share on other sites
rjsma

O que é que o IIS tem a ver com a memória?

Ficheiros grandes não devem ser colocado nos resources

queira utilizar esses sons como som de fundo das forms para isso tenho de ter os sons na mesma pasta da aplicação, existe outra maneira sem colocar os ficheiros no resource?

abraço

Share this post


Link to post
Share on other sites
jpaulino

Mas teres na mesma parta da aplicação não quer dizer que tem de estar nos resources.

Share this post


Link to post
Share on other sites
bioshock

O que é que o IIS tem a ver com a memória?

Outrora tive um problema idêntico, li um tutorial que me dizia para reiniciar o IIS, e funcionou.

Share this post


Link to post
Share on other sites
bioshock

queira utilizar esses sons como som de fundo das forms para isso tenho de ter os sons na mesma pasta da aplicação, existe outra maneira sem colocar os ficheiros no resource?

abraço

Existe. Mete-os na pasta bin/debug, e vais busca-los via código. Ou seja My.Application.Startup

Share this post


Link to post
Share on other sites
rjsma

anda ver se não digo nenhuma asneira  :D

não seria uma coisa assim?

My.Application.Startup("\bin\Debug\nomedoficheiro")

Tou a usar 2 botoes um para reproduzir o som outro para parar, não sei se assim vou conseguir.

Share this post


Link to post
Share on other sites
jpaulino

Outrora tive um problema idêntico, li um tutorial que me dizia para reiniciar o IIS, e funcionou.

IIS é para web!

Share this post


Link to post
Share on other sites
rjsma

já consegui, ficou assim

My.Computer.Audio.Play("H:\...", AudioPlayMode.BackgroundLoop)

mas não ha da para por so isto"\bin\debug\nome do ficheiro.wav" em vez de estar a por a directoria completa, assim se mudar a aplicação de sitio o som não funcionará

Share this post


Link to post
Share on other sites
bioshock

IIS é para web!

Eu sei. Mas por mais estranho que pareça, funcionou.

anda ver se não digo nenhuma asneira  :D

não seria uma coisa assim?

My.Application.Startup("\bin\Debug\nomedoficheiro")

Tou a usar 2 botoes um para reproduzir o som outro para parar, não sei se assim vou conseguir.

O My.Application.Startup já se está a dirigir a essa pasta.

Tem de ser algo como isto:

Application.StartupPath & "\tiesto.mp3"

Share this post


Link to post
Share on other sites
rjsma

ja está, fica aqui a solução pode haver alguem que pode a vir ter a mesma duvida

My.Computer.Audio.Play(Application.StartupPath & "\nome.wav", AudioPlayMode.BackgroundLoop)

obrigado pela a vossa ajuda  :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.