Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

jmaocubo

[RESOLVIDO]Localizar e completar

Mensagens Recomendadas

jmaocubo

Olá a todos

Preciso da vossa ajuda para completar um trabalho.

É o seguinte:

Na folha 1 tenho uma tabela de tamanho variável, cuja coluna A tem um código de um produto,

na coluna B o nome do produto e na coluna C o valor do produto.

Na folha 2 tenho um formulário de venda com o mesmo aspecto.

O que pretendia era um código em VBA que identifique que códigos tenho na folha 2 e completasse com os dados da folha 1.

Alguma sugestão?

Desde já agradeço qualquer ajuda que me possam facultar.

Comecei com este código, mas não me parece que lá vá  :fartnew2:

Sub localizar()

    Cells.Find(What:="70100000", After:=ActiveCell, LookIn:=xlFormulas, _
        LookAt:=xlPart, SearchOrder:=xlByRows, SearchDirection:=xlNext, _
        MatchCase:=False, SearchFormat:=False).Activate
        
    Cells.Find(What:="70200000", After:=ActiveCell, LookIn:=xlFormulas, _
        LookAt:=xlPart, SearchOrder:=xlByRows, SearchDirection:=xlNext, _
        MatchCase:=False, SearchFormat:=False).Activate
        
End Sub

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
FreiNando

Podes usar a formula PROCV sem recorrer a VBA, desde que mantenhas a folha 1 ordenada e como matriz para a procura utiliza as colunas completas.

Exemplo da formula para a celula "B2"  com "A2"=[Código do Produto]:  =PROCV(A2;'Folha 1'!A:C;2;FALSO)


O caminho mais curto para conseguir fazer muitas coisas é fazer uma de cada vez. Samuel Smiles

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
jmaocubo

Podes usar a formula PROCV sem recorrer a VBA, desde que mantenhas a folha 1 ordenada e como matriz para a procura utiliza as colunas completas.

Exemplo da formula para a celula "B2"  com "A2"=[Código do Produto]:  =PROCV(A2;'Folha 1'!A:C;2;FALSO)

Obrigado

Vou optar pela tua sugestão, parece-me ser a mais lógica e simples.

Abraço

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.