Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

Sign in to follow this  
jmaocubo

[RESOLVIDO]Localizar e completar

Recommended Posts

jmaocubo

Olá a todos

Preciso da vossa ajuda para completar um trabalho.

É o seguinte:

Na folha 1 tenho uma tabela de tamanho variável, cuja coluna A tem um código de um produto,

na coluna B o nome do produto e na coluna C o valor do produto.

Na folha 2 tenho um formulário de venda com o mesmo aspecto.

O que pretendia era um código em VBA que identifique que códigos tenho na folha 2 e completasse com os dados da folha 1.

Alguma sugestão?

Desde já agradeço qualquer ajuda que me possam facultar.

Comecei com este código, mas não me parece que lá vá  :fartnew2:

Sub localizar()

    Cells.Find(What:="70100000", After:=ActiveCell, LookIn:=xlFormulas, _
        LookAt:=xlPart, SearchOrder:=xlByRows, SearchDirection:=xlNext, _
        MatchCase:=False, SearchFormat:=False).Activate
        
    Cells.Find(What:="70200000", After:=ActiveCell, LookIn:=xlFormulas, _
        LookAt:=xlPart, SearchOrder:=xlByRows, SearchDirection:=xlNext, _
        MatchCase:=False, SearchFormat:=False).Activate
        
End Sub

Share this post


Link to post
Share on other sites
FreiNando

Podes usar a formula PROCV sem recorrer a VBA, desde que mantenhas a folha 1 ordenada e como matriz para a procura utiliza as colunas completas.

Exemplo da formula para a celula "B2"  com "A2"=[Código do Produto]:  =PROCV(A2;'Folha 1'!A:C;2;FALSO)


O caminho mais curto para conseguir fazer muitas coisas é fazer uma de cada vez. Samuel Smiles

Share this post


Link to post
Share on other sites
jmaocubo

Podes usar a formula PROCV sem recorrer a VBA, desde que mantenhas a folha 1 ordenada e como matriz para a procura utiliza as colunas completas.

Exemplo da formula para a celula "B2"  com "A2"=[Código do Produto]:  =PROCV(A2;'Folha 1'!A:C;2;FALSO)

Obrigado

Vou optar pela tua sugestão, parece-me ser a mais lógica e simples.

Abraço

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.