Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

Sign in to follow this  
hesilva

como fazer consultas no excel

Recommended Posts

hesilva

Boa tarde, estou com uma pequena duvida k é a seguinte. eu tenho numa folha de excel uma tabela varias celulas, sendo a primeira o nome do artigo; modelo;quantidade; etc...eu usei a funcao procv para encontrar o k kero, o problema é ques esta tabela é de registo de fornecimentos, ou seja, tipo cardex... o material irá aparcer mais vezes ao ser fornecido varias vezes, o meu problema é que o procv so mostra o primeiro que encontra...existe alguma outra funcao ou será melhor com filtros ...e como?dá para associar a uma macro certo?

Share this post


Link to post
Share on other sites
MetalFatigue

Se queres um resumo de cada artigo ou seja as somas de quantidades etc. podes experimentar a BDSOMA. Podes até conciliar o BDSOMA com procv's e obter um resumo completo facilmente bastando para isso colocar por exemplo o número do artigo.

Se queres mesmo o detalhe tens de ir por macros.

Share this post


Link to post
Share on other sites
hesilva

Ok, obrigado vou ver o que consigo fazer. Desculpem o uso dos K´s  😳 ja digo se consegui  :thumbsup:

Share this post


Link to post
Share on other sites
joseA

Aqui outra solução possível:

=SOMARPRODUTO((A6:A10>3022)*(B6:B10>4)*(C6:C10<10)*D6:D10)

Sendo que poderias usar as células A3; B3 e C3, substituindo assim (retirando apenas os sinais < e >):

A3 3022; B3 4 e C3 10

Ou seja:

=SOMARPRODUTO((A6:A10>A3)*(B6:B10>B3)*(C6:C10<10)*D6:D10)

:cheers:

Share this post


Link to post
Share on other sites
joseA

🤔 pois e jose! prefiro assim  ;) thks

😲

Asim como? A 1ª opção ou com a função SOMARPRODUTO?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.