Jump to content
Sign in to follow this  
kazzx

[RESOLVIDO] Erro na BD após instalar executavel - AccessDatabaseEngine em falta

Recommended Posts

kazzx

viva,

criei a minha aplicação, criei o executável e instalei-a num outro pc.

após testar a aplicação é me dado este erro:

The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.

o que estará na origem disto?

Share this post


Link to post
Share on other sites
José Lopes

sera que o outro tem o office 2007 instalado????


Quando te pedirem peixe.... ensina-os a Pescar!!Hum..lálálálá!!

Share this post


Link to post
Share on other sites
scorch

sera que o outro tem o office 2007 instalado????

E mais especificamente, o Access?


scorch_pp.png

PS: Não respondo a perguntas por mensagem que podem ser respondidas no fórum.

Share this post


Link to post
Share on other sites
José Lopes

e porque não usares usares o drivers nativos .NET?


Quando te pedirem peixe.... ensina-os a Pescar!!Hum..lálálálá!!

Share this post


Link to post
Share on other sites
vasco16

Consigo executar aplicações sem o access instalado.. mas eu faço sempre na versao 2003 do office agora em relaçaõ ao 2007 nao sei se o caso muda..

Share this post


Link to post
Share on other sites
vasco16

já sei do que era, porque faltava instalar um driver chamado AccessDatabaseEngine.

no outro pc ficou a dar :)

Era necessário o access instalado?

Share this post


Link to post
Share on other sites
kazzx

o outro tinha o 2007 instalado, mas só com esse driver é que consegui executar a aplicação.

opah, eu posso também testar num pc onde não tenha Access 2007 e depois dizer algo..

Share this post


Link to post
Share on other sites
vasco16

o outro tinha o 2007 instalado, mas só com esse driver é que consegui executar a aplicação.

opah, eu posso também testar num pc onde não tenha Access 2007 e depois dizer algo..

Se tiveres oportunidade agradeço. :)

Share this post


Link to post
Share on other sites
kazzx

opah no meu pc onde não tenho o Office 2007 instalado não deu nem com a instalação do driver, nada.

mas isso é no meu. experimenta no teu.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.