Jump to content

IE / Opera vs Firefox


JPVieira

Recommended Posts

Boa noite,

tenho um formulário que utiliza o método POST, e tenho 3 submits: da seguinte forma:

PHP Code:


        <td align=center><input type='image' src='images/cancel_btn.png' name='cancelar' value='Cancelar'/></td>

        <td align=center><input type='image' src='images/submit_btn.png' name='submeter' id='submeter' value='Submeter'/></td>

        <td align=center><input type='image' src='images/preview_btn.png' name='verantes' value='Ver Antes'/></td>


de seguida na página onde é tratado os dados do formulário, faço da seguinte forma:

PHP Code:


<?php

    session_start();

    if(($_SERVER['REQUEST_METHOD'] == 'POST') || ($_SESSION['preview_basico']==1))
    {
        if($_POST['submeter']=='Submeter')
        {
          [...]
        }
        elseif($_POST['verantes']=='Ver Antes')
        {
          [...]
        }
        elseif($_POST['cancelar']=='Cancelar')
        {    
          [...]
        }
        elseif($_SESSION['preview_basico']==1)
        {
          [...]
        }
    }
    else
    {
          [...]
    }
?>


Até aqui tudo bonito, no firefox funciona perfeitamente, o problema é que no opera e no IE não funciona, pois as variáveis $_POST['..'] não tem valor nenhum.

Acredito que já muita gente passou por este problema, e gostaria que alguém me pudesse ajudar a contornar o mesmo.

Antes de mais, obrigado pela ajuda

Cumprimentos

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.