Jump to content
Sign in to follow this  
mendes88

algoritmo: area do rectangulo duvida

Recommended Posts

mendes88

boas

estou a começar a dar as primeiras noções de algoritmos

foi-me pedido um exercício que apesar de simples, gostaria de ir mais alem

exercício: fazer um algoritmo que calcule a área do rectângulo

algoritmo "area_rectangulo"
var
c,l,a:real
inicio
escreva ("indique o comprimento do rectangulo")
leia (c)
     se c<0 entao
     escreva ("Valor impossivel. indique outro valor")
     senao
     escreva ("indique a largura do rectangulo")
     leia (l)
     se l<0 entao
     Escreva ("valor impossivel. indique outro valor")
     senao
     a<- c*l
escreva ("A area é",a)
fimse
fimse

este foi o algoritmo que fiz.

a minha duvida consiste em saber se é possível fazer com que o programa depois de dar os erros de "valores impossiveis", volte a pedir o valor pretendido.

se da, gostava de saber que comando se utiliza e como o insiro ali no meio

muito obrigado :D

Share this post


Link to post
Share on other sites
renafi

Já aprendeste ciclos?

Basicamente terias que ter um que te fosse repetindo a inserção dos valores, até ter valores válidos.


Oracle Certified Professional - AdministraçãoOracle Certified Professional - Pl/sqlMCPD - Microsoft Certified Professional DeveloperMCTS - Microsoft Certified Technology Specialist

Share this post


Link to post
Share on other sites
softklin

Esses mesmo. A condição de paragem pode ser uma pergunta, em que o utilizador é confrontado com a possibilidade de calcular (introduz S, 1, ...) ou terminar a execução (N, -1, ...).

Se souberes bem a diferença entre o "para" e o "enquanto", a tua escolha do ciclo vai ser igual à do Baderous. Se tiveres dúvidas, colocas aqui. :confused:


Nick antigo: softclean | Tens um projeto? | Wiki P@P

Ajuda a comunidade! Se encontrares algo de errado, usa a opção "Denunciar" por baixo de cada post.

Share this post


Link to post
Share on other sites
mendes88

boas

grande ajuda mesmo. com a função enquanto realmente consegui fazer aquilo que eu queria

deixo aqui o algoritmo final já todo direitinho :confused:

algoritmo "area_rectangulo"
var
c,l,a:real
u:caracter
inicio
Escreval ("Indique as unidades de medida.")
Leia (u)
Escreval ("Indique o comprimento do rectângulo.")
leia (c)
     enquanto c<0 faca
              escreval ("Valor inválido. Indique um novo valor: ")
              leia (c)
     fimenquanto
Escreval ("Indique a largura do rectângulo.")
Leia (l)
     enquanto l<0 faca
              escreval ("Valor inválido. Indique um novo valor: ")
              leia (l)
     fimenquanto
a <- c*l
escreval ("A área do rectângulo é ", a, u, "2.")
fimalgoritmo

neste já adicionei uma função para verificar as unidades de medida e assim completar a resposta do ultimo "escreva".

obrigado a todos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.