Jump to content

[Resolvido] - Problema com caracteres portugueses


LCarreira

Recommended Posts

Boa tarde,

Há já algum tempo que desenvolvo uma aplicação em .NET e só agora reparei que tenho um problema no que toca à utilização de caracteres do abecedário português... (àáãçâ...)

Nos meus formulários utilizo regularmente um botão que abre um pop-up. este pop-up contém uma grid com dados de uma tabela de modo a facilitar o preenchimento fo form principal...

No meu Web.config tenho já:

<system.web>
<globalization culture="pt-PT" uiCulture="pt-PT" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1" fileEncoding="iso-8859-1" />
</system.web>

Contudo quando escolho um item da grid no pop-up passa o valor com caracteres esquisitos no caso de se tratar dos tais caracteres portugueses. Se não tiver acentos passa correctamente...

Ex. Ao escolher o nome josé passa para o form principal -> jos&#233;

Também já utilizei:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

No ficheiro .aspx do pop-up, mas também não obtive resultados...

Agradecia a vossa ajuda... :wallbash:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.