Ir para o conteúdo
rjsma

Web browser

Mensagens Recomendadas

bruno1234    20
bruno1234

A form 5 tem alguma referencia para a form 1?

Devias ter isso melhor organizado, as forms devem estar todas ao mesmo nivel e não devem referenciar-se umas ás outras.

Se precisas de trocar informações entre elas, essas informações devem estar numa camada de gestão acima dos forms.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
rjsma    2
rjsma

o meu problema nao e trocar informacoes entre as forms

o erro que da e com o navigate

diz que o navigate nao e membro do system.windows.forms.tabcontrol

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
ribeiro55    44
ribeiro55

Isso dá a entender que o teu TabControl tem como nome "WebBrowser".

Vê-lá se não deste o nome de "Webbrowser" ao tabcontrol por engano...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
ribeiro55    44
ribeiro55

Eu percebi na primeira imagem. E continuo a dizer o mesmo.

O que a IDE te está a dizer é que a referência por detrás do nome "webbrowser" não possuí o método Navigate, diz aliás que o método Navigate não é membro da classe TabControl.

A única conclusão que se tira é que estás a dar o nome "webbrowser" ao teu TabControl.

É normal que se cometa esse erro porque é fácil baralhar os cliques entre TabControl, TabPage e o que lá está dentro.

Procura na tua caixa Properties, numa combobox que lá está a listar todos os controlos no form, o nome "webbrowser" e verifica o tipo.

Em adição, procura também o tipo webbrowser e verifica com que nome está realmente.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
ribeiro55    44
ribeiro55

Isso diz, mais uma vez, que o nome WebBrowser pertence a um TabControl.

É natural que o tabcontrol não tenha o método Navigate :D

Descobre na lista dessa combobox, o webbrowser para veres que nome tem e onde raio se enfiou no form.

Recriei o que provavelmente tens aí e mostro também como aparece um webbrowser, aqui.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
ribeiro55    44
ribeiro55

ja consegui navegar com uma tab control

Não estou a duvidar nem nada disso... mas mostra lá um TabControl a navegar a web, sem um webbrowser.

Eu acho que estás a fazer uma tremenda confusão  :D

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade