Jump to content

Excel


oELDER

Recommended Posts

Boas tenho aqui um problema que me parece facil mas nao tou a chegar la

o objectivo e este:

existem varios NOMES aos quais sao colocados a PONTUAÇAO da semana e quero que os tres primeiros da semana fiquem com o VALOR de 0 enquanto que todos os outros fiquem com o valor 1

se fosse so para o que tivesse a melhor pontuaçao era facil tratava se apenas de algo como =SE(B3=MÁXIMO(B$3:B$14);0;1)

mas com os tres primeiros nao tou a conseguir la chegar

aqui fica um exemplo de como quereria que ficasse

desde ja um obrigado

Nomes            pontuaçao        valor

manel              10                    0

joaquin            9                    1

fernando          5                    1

joao                15                    0

andre              23                  0

francisco          8                    1

antonio              7                    1

pedro                2                    1

ja agora sao 12 nomes, nao sei se fara diferença mas fica ja aqui referido

Uma outra coisa o meu office e portugues pelo que o excel so aceita formulas em portugues

Novamente obrigado

Link to comment
Share on other sites

ja consegui achar os top tres

tenho assim

=MAIOR(D3:D14;1)        que vai dar 23

=MAIOR(D3:D14;2)        que vai dar 15

=MAIOR(D3:D14;3)        que vai dar 10

agora queria por assim numa celula

por exemplo para o 23, ou seja o 1 classificado: caso 23 se encontre na tabela entao 0 senao 1

para dar o top 3 com o valor 0 e os restantes com o valor 1

Nomes            pontuaçao        valor

manel              10                    0

joaquin            9                    1

fernando          5                    1

joao                15                    0

andre              23                  0

francisco          8                    1

antonio              7                    1

pedro                2                    1

basicamente quero assim, caso encontre o numero da tabela do top 3 na tabela da pontuaçao da 0, caso nao haja a correspondencia da 1

espero que o meu portugues e a minha intençao esteja bem explicada

obrigado desde ja

Link to comment
Share on other sites

porque e para continuar indefinidamente a juntar pontuaçoes e somar valores.

alguem podia ajudar neste ultimo passo?

obrigado

tentei fazer algo do genero =OU(SE($D$22=D3;0;1);SE($D$23=D3;0;1);SE($D$24=D3;0;1)) mas nao deu

sendo que o d3 e a pontuaçao e o d22 a d24 e o top 3 que e achado

Em portugues e feito a mao seria assim que faria mas esqueci me que o ou so da verdadeiro ou falso

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.