Ir para o conteúdo
Chamuanza

Falta de Registo em Combobox

Mensagens Recomendadas

Chamuanza    3
Chamuanza

Oi Pessoal eis-me aqui de novo com mais um berbicacho

tenho uma combobox que carrego atraves de uma tabela criada no SqlServer2005 com 9 registos, mas quando clico para abrir a combo aparecem-me todos os registos menos o primeiro e no seu lugar vem "System.Data.DataRowView"

Tenho a combobox com as propriedades SelectedItem=CategoriaBindingSource - Categoria e

SelectedValue=CategoriaBindingSource - Categoria e Text=PrincipalBindingSource - Categoria que é a tabela onde vai por o valor selecionado.

Se eu seleccionar System.Data.DataRowView para ver o que dá, aparece um erro "dAdapter.Fill(dset)" - Invalid object name 'System.Data.DataRowView'.

O que será que está mal nisto?

Será que esta informação chega para se perceber?

Desde já obrigado

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
passado    0
passado

bem eu uso um sistema particido ao teu mas nao fiz assim, a mim bastoume ir á combobox e na setinha do canto superior direito escolhi primeiro a base de dados depois o valor que queria mostrar e depois o que queria guardar, e depois no botao add e que coloquei a propriedade de ir buscar o valor da combobox, e tudo dá certo, nao sei se te ajuda....

Já agora aproveito e esponho um problema que e so quando coloco para visualizar nem sempre ele mostra o valor so depois de clicar para visualizar outro....

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Chamuanza    3
Chamuanza

quanto a primeira parte,verifiquei as propriedades e penso que está tudo bem, no entanto continua a suceder o mesmo, falta-me o primeiro item na combo e aparece-me System.Data.DataRowView.

No que se refere a tua questão tambem a mim me sucede o mesmo,quando seleciono um item não me apareceo valor, somente quando mudo de combo e que o valor da combo anterior aparece

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
jpaulino    106
jpaulino

E se mostrares como está a preencher a combobox ?

A ordem correcta é definir a datasource primeiro e depois o displaymember e valuemember.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Chamuanza    3
Chamuanza

sim utilizei os wizards para preencher a combo

Tambem fiz um relacionamento entre tabelas, e acho que tenho para ali fiasco,como e que posso enviar essa parte do relacionamento das tabelas a ver se tenho algo errado (quase de certeza) ou se poderei fazer de outro modo o que pretendo

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade