Ir para o conteúdo
Sir Pereira

Carácteres esquisitos

Mensagens Recomendadas

Sir Pereira    3
Sir Pereira

Boas pessoal,

instalei agora um skin do WordPress, mas aquilo no menu aparece-me com uns caracteres esquisitos:

caracteres.jpg

Como corrigir?

Cumps

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Sir Pereira    3
Sir Pereira

Estás a usar o IE? Acho que pode ser do tipo da codificação dos caracteres.

Também penso que seja isso.

Estou a usar Firefox.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
scorch    19
scorch

Depende. Se a codificação estiver mal definida no firefox, vais a Ver -> codificação de caracteres e escolhes a codificação.

Se o problema for da skin, deve ter lá no código da skin uma codificação errada. Não sei se é uma tag <meta>, mas acho que é.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Sir Pereira    3
Sir Pereira

<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />

É este o código que tenho lá. O mais esquisito é que eu no site tenho configurado utf8 e utf8 suporta os acentos e tudo.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
scorch    19
scorch

Então, faz ver código fonte e se os caracteres forem assim:  À (por exemplo) em vez de Á está descoberto o problema. Só não sei como o solucionar, pois nunca trabalhei com o source do WordPress.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Sir Pereira    3
Sir Pereira

Então, faz ver código fonte e se os caracteres forem assim:  À (por exemplo) em vez de Á está descoberto o problema. Só não sei como o solucionar, pois nunca trabalhei com o source do WordPress.

O código que aparece é: � .. aparece mesmo este símbolo

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
scorch    19
scorch

Então não sei. Em princípio, isso é gerado através do PHP. Este deve mandar já esse símbolo.

Alguém que já tiver mais experiência com o WordPress poder-te-á ajudar melhor.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
djthyrax    11
djthyrax

Isso é problemas de charset. O conteúdo está em UTF-8 mas o encoding que ele diz que tem é ISO-8859-15 p.e., a solução passa por 1) usar entities ou 2) converter tudo para o mesmo encoding.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade