Ir para o conteúdo
xploit

apache x caracteres

Mensagens Recomendadas

xploit    3
xploit

Boas pessoal eu utilizo o apache2triad como servidor local para testes , mas sempre tive um problema com ele e nunca resolvi fui sempre adiando mas já se torna irritante, que é o problema de caracteres.. todas as páginas que eu visualize nele aparecem me assim "Compre créditos!" e assim sucessivamente em todas as palavras que tenham acento.. o que puderá ser sugestões?

Cumps

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Nuvem    0
Nuvem

Tens de normalizar os dados.

É boa práctica (e importante) definir tabelas de caractéres para todas as páginas de um site, inclusive das tabelas das bases de dados.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
xploit    3
xploit

ou seja não é possível por o apache2triade a utilizar utf-8 ? é a codificação que utilizo nas minhas páginas, o mesmo acontece com o dreamweaver cs3 que utilizo, abro ficheiros por exemplo .php, altero e faço save e meto no meu servidor remoto (não local) e vejo  os caracteres todos lixados, para resolver isto abro um txt copio o codigo todo la para dentro e faço save com o codigo exactamente igual e meto no servidor e aparece com os caracteres perfeitos todos reconhecidos.. não percebo estas cenas no mínimo estranho , ja meti o meu DW com codificação utf-8 , e meto sempre os header com o mesmo..

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Nuvem    0
Nuvem

Configura-o para gravá-los com codificação ANSI.

Quando falei de normalização de dados, estava a falar do charset em si da página, a.k.a., pelo header de Content-Type.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
xploit    3
xploit

exacto, pois mas isso estão todas configuradas com header utf8 aliás tenho um htaccess que padroniza todas as páginas html,php,js para UTF8 automáticamente, mas como posso configurar o dreamweaver para ANSI? onde alterei para UNICODE foi em edit > preferences > New document e alterei para unicode lá, não tem é ANSI.. onde consigo essa configuração?

Cumps tks pela ajuda

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade