Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #57 da revista programar. Faz já o download aqui!

pakito87

[duvida]C/C++ no MAC

Mensagens Recomendadas

pakito87    0
pakito87

recentemente adquiri um MAC e instalei o Xcode, o problema é que estou a começar a trabalhar com varios ficheiros de C os chamados headers files. Qd eu programo no windows corre td bem compila etc, mas o mesmo já não acontece no Xcode, apesar de ser um programa elegante parece ter alguns bugs. Sendo assim alguém me poderia informar uma solução? Sem passar por criar uma partição para o windows claro

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Knitter    101
Knitter

Se não compila deverás ter um conjunto de erros que provocaram a falhar de compilação, que erros são? É que, embora acredite que exitam bugs no XCode, duvido que estejas a encontrar um :cheesygrin:

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
pakito87    0
pakito87

A questão não está nos erros, porque supostamente deveria de funcionar, sendo que corre perfeitamente no visual studio e no dev c++;

mas assim que tiver em casa posto a lista de erros

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Rui Carlos    309
Rui Carlos

A questão não está nos erros, porque supostamente deveria de funcionar, sendo que corre perfeitamente no visual studio e no dev c++;

Se estiveres a usar apenas standard C, devia funcionar, mas quase que apostava que não funciona porque estás a usar coisas que são específicas de um determinado SO.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
pakito87    0
pakito87

imagem -> http://img10.imageshack.us/img10/1104/imagem2t.png

Código -> http://www.megaupload.com/?d=9I5IFQIQ

Aqui está uma imagem com os 2 erros que se repetem ao longo do código, deixo tb caso alguem se queira analisar o código que fiz no dev c++;

Já arranjei um programa que lê o headfiles no mac, chama-se Codeblocker.

Obrigado pelas ajudas :cheesygrin:

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Knitter    101
Knitter

Sinceramente não percebi qual foi o problema que tiveste, testei o teu código e funcionou à primeira, tanto em XCode como em NetBeans IDE, se encontraste outro que funciona, creio que o problema estaria na forma como criaste o projecto ou como o adicionaste ao XCode.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
pakito87    0
pakito87

Sinceramente não percebi qual foi o problema que tiveste, testei o teu código e funcionou à primeira, tanto em XCode como em NetBeans IDE, se encontraste outro que funciona, creio que o problema estaria na forma como criaste o projecto ou como o adicionaste ao XCode.

Sim concordo cntg posso ter colocado de forma errada os ficheiros, porque já compilei vários programas no Xcode, mas adicionar headers files é a primeira vez. Se não for incomodo podes-me indicar onde foste para adicionar.

Exacto Rui, por isso é que dou razão ao knitter; até porque de facto uso este programa a bem pouco tempo e posso estar a fazer algo errado.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade