Ir para o conteúdo
fer

Iframe

Mensagens Recomendadas

fer

Boas,

Estou a tentar colocar um chat abrir dentro de uma página adicional da minha galeria em php.

Até funciona mas só parece um bocadito do topo do chat.

O código que estou a usar é.

<iframe src="http://www.fotogenico.net/site/chat/flashchat.php" heigth="100%" width="100%" frameborder="0" name="principal"></iframe>

Ela aparece assim como na imagem.

chat.jpg

Obrigado pela ajuda. ;)

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
djthyrax

Troca o heigth e o width por um style para usares aí os valores relativos.


Não peças ajuda por PM! A tua dúvida vai ter menos atenção do que se for postada na secção correcta do fórum!

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
The Loser

Valores relativos são percentagens.

Se usares a propriedade style dentro da tag de iframe, podes "moldá-la" com CSS.. Que te permite o uso de valores relativos.

À parte, isto estará na secção certa? Parece-me algo mais direccionado para XHTML ou CSS.. :)


I intend to live forever. So far so good.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
djthyrax

Algo como isto:

<iframe style="width:100%; height:100%" bla bla bla>


Não peças ajuda por PM! A tua dúvida vai ter menos atenção do que se for postada na secção correcta do fórum!

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
fer

Algo como isto:

<iframe style="width:100%; height:100%" bla bla bla>

Obrigado,

Mudei para isto mas ficou igual.

<iframe style="width:100%; height:100%" src="http://www.fotogenico.net/site/chat/flashchat.php" frameborder="0" name="principal"></iframe>

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
djthyrax

Mostra o código todo da página gerada.


Não peças ajuda por PM! A tua dúvida vai ter menos atenção do que se for postada na secção correcta do fórum!

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
vbtipo

Invés disto:

<iframe src="http://www.fotogenico.net/site/chat/flashchat.php" heigth="100%" width="100%" frameborder="0" name="principal"></iframe>

experimenta assim

<iframe src="http://www.fotogenico.net/site/chat/flashchat.php" heigth='100%' width='100%' frameborder="0" name="principal"></iframe>

Em principio já resolve esse problema ... depois diz alguma coisa ...


Lema: Se eu não saber de alguma coisa não se preocupem porque tento sempre ajudar alguma coisita, nem que seja, por palpites/sugestões.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
djthyrax

O uso de plicas ou aspas não pode fazer qualquer diferença.


Não peças ajuda por PM! A tua dúvida vai ter menos atenção do que se for postada na secção correcta do fórum!

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
pedrotuga

Viva... esse problema e devido ao doctype do teu html.

As páginas com iframe não podem ter alguns doctypes porque dá caldo. Uma solução tipo fita cola é removeres o doctype da página que tem o chat. A solução como deve ser é usares um doctye apropriado para o uso de frames, pessoalmente não sei qual é.

É uma questão de pesquisares e experimentares.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
fer

Boas,

Obrigado pela vossa ajuda.Ainda não consegui mas é uma questão de pesqueisar mais um pouco.

Assim que conseguir resolver o problema deixo aqui a solução.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.