Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

pho3nix

Google Appengine

Recommended Posts

pho3nix

Estou me a iniciar no appengine que axo uma bela plataforma e espero que evolua como tal.

Mas aqui vai o meu problema tenho o seguinte app.yaml

application: new-project-template

version: 1

runtime: python

api_version: 1

handlers:

- url: /profile/.*

  script: profile.py

- url: /.*

  script: main.py

em que quando faço http://localhost:9999/profile/ dá-me sempre erro 404 estou a fazer bem é assim que se mapeia o script profile.py?

Share this post


Link to post
Share on other sites
pedrotuga

Eu cá só uso um ficheiro e faço lá o mapeamento de urls. Evito de andar a configurar coisas em mais sítios diferentes.

Mas segundo a documentação, sim é assim

http://code.google.com/appengine/docs/configuringanapp.html

Nao estou a perceber porque é que não funciona.

podes experimentar assim:

- url: /profile

sicript: profile.py

ou adicionar mais qq coisa no url, mas sinceramente parece-me que tens bem.

EDIT: é uma optima plataforma, finalmente alguem que tambem está a experimentar.

Não estás por acaso a usar outra porta que não a 9999?

Share this post


Link to post
Share on other sites
newbeen

Conto começar a fazer experiências com isso brevemente para por o meu blog pessoal, todo o gato pingado tem um eu como bom português não quero ser diferente alem de ser uma excelente oportunidade e terreno para experiências e provas de conceito  :P


RHCE - 120-062-534

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.