Jump to content
MacgyverPT

[Resolvido][Dúvida] Permissões num forum SMF

Recommended Posts

MacgyverPT

Boas pessoal,

Eu tenho aqui um fórum, e queria criar permissões para grupos de utilizadores. A estrutura do forum é +/- representada em baixo:

-> Quadro 1

--> Sub-Quadro1

--> Sub-Quadro1

-> Quadro 2

--> Sub-Quadro2

-> Quadro 3

Eu queria fazer com que o utilizador A só tivesse acesso ao Quadro 1 (e seus sub-quadros) e Quadro 3, como faço isso?

Já criei um grupo chamado "Outros" e disse que este grupo so tinha acesso aos Quadros 1 e 3. Criei o utilizador A e coloquei-o dentro do grupo "Outros".

O problema esta quando vou fazer login com esse utilizador, este tem acesso a todo o fórum.. O que não devia...

Cump.

M.offspring.R

Share this post


Link to post
Share on other sites
HecKel

O problema é que os outros quadros devem estar visíveis a todos os utilizadores, portanto todos terão acesso :)

Verifica quem é que tem acesso ao Quadro 2 e vê se o utilizador A está dentro de algum desses grupos, se sim encontraste o problema :)

Share this post


Link to post
Share on other sites
MacgyverPT

ja andei de roda isto e não consigo fazer  :wallbash:

Devo estar a fazer alguma coisa de errado...

Share this post


Link to post
Share on other sites
HecKel

Tens a possibilidade dos membros de grupos baseados em mensagens verem o quadro? Por norma esses devem estar desactivados pois isso pode dar problemas desse género, verifica isso, sff.

Share this post


Link to post
Share on other sites
MacgyverPT

Heckel, o que eu fiz foi:

Criar o grupo:

-> criei um grupo baseado no "restritivo"

-> Nos quadros visiveis seleccionei os quadros 1 e 3

Criacao do user:

-> criei o user

-> adicionei esse user ao grupo que tinha criado anteriormente

Mas depois ao fazer login com esse user, ele tem acesso aos quadros todos, o que não devia...

Share this post


Link to post
Share on other sites
MacgyverPT

AS permissões ainda estão de origem, e não tenho nada baseado em números de mensagens.

A versão é a 1.1.5.

Share this post


Link to post
Share on other sites
MacgyverPT

Já consegui resolver o problema.

Tinha que desactivar umas opções e activar o "outros" para aceder a determinado "quadro" ou "sub-quadro".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.