Ir para o conteúdo
flyzone

Problema ao copiar dados de uma gridview para uma textbox

Mensagens Recomendadas

flyzone    0
flyzone

Boa tarde..

Estou com o seguinte problema.

Tenho uma gridview de onde copio vários dados para várias textbox até aqui não existe problema.

O problema está quando os dados (texto) na gridview  têm assentos pois ao passar para a textbox ficam "esquisitos.

Como se pode ver neste exemplo o nome está mal.

"http://storage.com.sapo.pt/11.jpg

Alguém sabe como resolver este problema!?

Obrigado.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
jpaulino    106
jpaulino

O problema é que a textbox tem um encoding automático e as labels não, por isso nas labels não dá problema.

Utiliza:

TextBox1.Text = HttpUtility.HtmlEncode(ValorDaGridView)

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
flyzone    0
flyzone

Obrigado pela a ajuda.

Andei a pesquisar sobre isso do "HtmlEncode" e acabei por chega à gridview e desabilitar o "HtmlEncode" das colunas que me estavam a dar problemas, assim não tive mais problemas. :D

Obrigadão.

:P

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
jpaulino    106
jpaulino

Andei a pesquisar sobre isso do "HtmlEncode" e acabei por chega à gridview e desabilitar o "HtmlEncode" das colunas que me estavam a dar problemas, assim não tive mais problemas. :P

Mas não falaste em problemas nas colunas mas sim na textbox, por isso coloquei aquele exemplo. O HtmlEncode = False deve estar não colunas que possam ter codificação e criar problema, assim com nas datas que se quer formatar.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade