Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #57 da revista programar. Faz já o download aqui!

xplode_me

Não consigo ler variáveis $_POST

Mensagens Recomendadas

xplode_me    1
xplode_me

Olá!

Em http://www.planetuga.com/conta tenho 2 campos para enviar dados por POST para um login.php.

A questão é que os $_POST (qualquer um) chega sempre vazio ao login.php. Alguém já passou por algo semelhante? O mesmo código noutros 2 servidores funciona 5*.

Abraço!

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
psiico    1
psiico

posta o codigo, era mais facil. mas pode ser de o server nao suportar short_tags ou assim 1 cena parecida em vez de usares: "<?" teres q usar "<?php".

Eu nao sei tou a falar de cor.

Coloca o código para ver

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
neverdie    0
neverdie

Assim a que é:

<form action="login.php" name="login" method="post">

Login:

<INPUT type="text" name = "login">

<br>

Password:

<INPUT type="password" name="password">

</form>

login.php:

<?

        $login = $_POST['login'];

  $password = $_POST['password'];

 

echo $login;

echo $password;

?>

boa sorte!

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
xplode_me    1
xplode_me

Hm, depois de alterar o código de modo a que os formulários não fossem o resultado de echo's php, tudo funciona bem. Estranho??

tive de passar de echo "<form etc etc"; para código html sem nada de echos. Funciona 100%.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade