Ir para o conteúdo
cetus

Scroll na página.

Mensagens Recomendadas

cetus    0
cetus

Viva,...

Estou a fazer uma página em Flash, só consigo usar o scroll do mouse para deslocar a página para cima e para baixo, se colocar a seta do mouse numa pequena área do lado direito da página...Alguem sabe porquê??? E como resolver?

Obrigado..

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
cetus    0
cetus

Correcção: O scroll do mouse funciona apenas na 1ª pagina(inicial)...depois de abrir outro .swf e fazer unload ao mesmo.. o scroll ja noa funciona na 1ªpagina (inical).

:)

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
dimen    0
dimen

Não estou a perceber muito bem o problema. Tu tens a primeira página que tem um scroll interno e depois fazes load de outro movieclip e o scroll desaparece, é isso?

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
cetus    0
cetus

Dimen, antes de mais agradeço toda a ajuda q me tens dado... :)

Quando digo "scroll" refiro-me á roda q o rato tem, que permite entre outras coisas, deslocar as páginas web na vertical...em vez de pegar na barra do I.Explorer... para visualizar a propria página de cima a baixo..

O situação é que quando abro a página inicial "home.swf" o dito "scroll" funciona na perfeição... ou seja, desloca a pagina inteira na vertical(cima e baixo)..

O mesmo "home.swf" tem varios botoes q abrem diferentes SWF's.. ex: botao1 -> file1.swf / botao2 -> file2.swf / botao3 -> file2.swf...etc

O problema é que depois de clicar num dos botoes e abrir por ex. o file2.swf......o "scroll" já nao funciona!!

Não sei se me fiz entender... :D

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
dimen    0
dimen

Sim, certo, estás a falar do scroll do rato...

O problema, no meu entender, está interligado com o tópico "Como carregar 2 ou mais swf via LoadMovie". Se estiveres a fazer o load dos ficheiros externos (file1.swf, file2.swf) para cima da _root, todas as funções que lá tenhas declarado desaparecem.

Ou seja, se tiveres no teu home.swf eventos registados, botões ou o que quer que seja, quando fazes loadMovie de algo para cima da _root, tudo isso desaparece. Tens duas formas de testares isso facilmente, uma colocando um trace sempre que entras no evento de mouseWheel, outra utilizando o debugger do flash.

Cumprimentos

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade