Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #57 da revista programar. Faz já o download aqui!

Fabriziopt

Erro esquisito

Mensagens Recomendadas

Fabriziopt    0
Fabriziopt

Boas

Bem quando entro no site apareceu me o seguinte:

Parse error: syntax error, unexpected $end in /home/a2362262/public_html/index.php on line 220

Quando fui ver a linha tava em branco :nono1:

Mas apaguei a linha e depois o erro passou para:

Parse error: syntax error, unexpected $end in /home/a2362262/public_html/index.php on line 219

Bem a linha só tem :

</html>

O que hei de fazer ??

Abraço

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
psiico    1
psiico

tipo esse erro é porque tem um if ou um while ou qualquer outra "função" por fechar, ou seja, falta uma } no fim...

ex:

if ($_POST['register']) {
include_once("config.php");

falta fechar o if com uma }

aconselho-te a usares um programa chamado PhPDesigner 2007 que tem highlight de codigo web (php, js, html, css, etc) e ele ajuda-te a encontrar o erro.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
psiico    1
psiico

S o programa o ajuda e  ele tem dificuldade em PHP, nao vai fazer download porque?

Como percebes de PHP nao precisas de uma "moleta" nem de ajuda, isso nao quer dizer que os outros nao precisem e tenham a mesma prespicácia que tu a analisar codigo e encontrar o problema.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
djthyrax    11
djthyrax

S o programa o ajuda e  ele tem dificuldade em PHP, nao vai fazer download porque?

Como percebes de PHP nao precisas de uma "moleta" nem de ajuda, isso nao quer dizer que os outros nao precisem e tenham a mesma prespicácia que tu a analisar codigo e encontrar o problema.

O problema já lho disseram que é uma } que falta. Custa muito indentar código e ver onde falta a }? É preciso um editor para isso? Jeez, até no notepad se faz isso...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Fabriziopt    0
Fabriziopt

Ahh , desculpa fiquei entretido a ver-vos discutir xD

Bem, era mesmo isso mas ainda não testei depois, de feita a alteração, o ficheiro, pois o meu Wamp não ta a dar, ainda não sei porque :(Logo que sober digo alguma coisa.

Desculpa ter demorado tanto.

Abraço

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
taviroquai    61
taviroquai

Ainda bem que está resolvido...

Já me aconteceu ter o código todo certo e esse tipo de erro aparecia-me na mesma... o que era??? A codificação do documento... não estava em ANSI.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade