Ir para o conteúdo
rui_fernandes

[vb.net 2005] Erros ao fazer BUILD SOLUTION ...

Mensagens Recomendadas

rui_fernandes    0
rui_fernandes

Boa tarde....

quando ia para fazer build solution, deu uma lista enorme de erros, mas se executar o programa e tudo nao me da erro nenhum....

porque sera ???

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Asgorath    0
Asgorath

Troca por

Dim ds As New System.Data.DataSet1

 ver se resolve o problema

A classe DataSet pertence a varios namespace por isso tens que dizer qual estas a usar.

A crystalreport é a mesma coisa.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
rui_fernandes    0
rui_fernandes

epah, fiz isso, mas ele define o objecto datset.

o dataset que eu tenh feito(DATASET1, entre muitos) e o k eu kero tas a perceber....

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
rui_fernandes    0
rui_fernandes

tipo, eu tenh isto tudo organizado, tipo, no sulution explorer tenh of form e dataset, reports, tudo e pastas...

exemplo, pasta artigos com form, report e dataset dentro, e clientes a mesma coisa... etc...

nao sei se é preciso meter o caminho de cada um...n sei...pode ser burrice minha....

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Asgorath    0
Asgorath

Boas.

Nunca me aconteceu o erro do ambigous mas tenho Imports System.Data.SqlClient em todos os forms que crio, de certeza que tens os imports tambem?

O meu projecto actual tem 4 projectos, 114 crystal reports, 143 forms, 8 datasets.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Asgorath    0
Asgorath

Imports System.Data.SqlClient 
Imports System.Data
Imports CrystalDecisions.CrystalReports.Engine
Imports CrystalDecisions.Shared

Com esses imports todos posso declara dim a new dataset1 sem problemas..

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
rui_fernandes    0
rui_fernandes

vou testar...

mas so mais uma coisa, a tua aplicacao deve estar distribuida p varias makinas penso eu...

cm fizest o setup ?

eu fiz com o do VS, mas os reports nao me funcionavam...

o tiago salgado deu a sugestao de fazer com Installshield, porreiro...mas cm tava c estes erros n dava...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
rui_fernandes    0
rui_fernandes

epah, nao funcionou c os namespaces...

mas peguei no k fiz ontem e ja n da erros...so tenh de pegar em poucas coisas k alterei...

pk ao fazer build,ou publish fica a funcinar direito os reports noutro pc's ?

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Asgorath    0
Asgorath

Faço sempre uma copia de segurança dos projectos ao fim do dia para dois discos.

Também usamos o Visual SourceSafe 2005 para fazer gestão de versões.

Segue o wizard do publish projecto, depois quanto terminar copia o setup.exe para o pc de destino para se funciona bem os reports.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
rui_fernandes    0
rui_fernandes

epah, nao da...

o publish n fica grande coisa, n se pode da o nome ao atalho k é criado, nao cria atalho no ambiente de trabalho, n se pode incluir na pasta onde e instalado uma BD p exemplo...a menos que de e eu n sei...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Asgorath    0
Asgorath

Tenta isto

add new project > other project types > setup and deployment > setup project

selecionar setup1 no solution explorer > right-click > add > project output

left-click no primary output > Ok

as detected dependencies ficam preenchidas.

Abre o configuracao manager e e muda para release e e faz rebuild do projecto de setup.

na directoria de nome do projecto de setup\release\ ha 1 setup.exe e um nomedoprojectosetup.msi .

copia os dois e tenta instalar ver os reports funcionam.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
rui_fernandes    0
rui_fernandes

Olha, vou mentir algumas coisas que disse do publish, ja tenho os reports a funcionar, ja me da um nome ao atalho que é criado nos programas, e ainda consigo fazer com que ele me instale framework, crystalreports,reportviews e mais umas coisas no pc onde vou fazer a instalacao da aplicacao.

so tem umas desvantagens, nao consigo por uma base de dados para ele colocar na pasta de instalacao (mas isto é o menos) , nao me cria atalho no ambiente de trabalho(tambem n é o problema) e ele faz a instalacao da aplicacao em "C:\Documents and Settings\Rui\Definições locais\Apps\2.0 ..." (isto ja pode ser um problema...)

nao sei isto assim so instala num utilizador...de resto acho que fica IN PACK ...

mas vou fazer isso k dissest passo a passo para experimentar.  :P

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade