Ir para o conteúdo
djthyrax

[Resolvido] Erro com caracteres especiais

Mensagens Recomendadas

djthyrax    11
djthyrax

Boas.

Estava a tentar fazer backups das minhas partições FAT para a NTFS e deu-me erro. Fui à consola e fiz um teste:

[djthyrax@dawn /media/disk-1/Athlon64]$ sudo cp -r Morangos\ Com\ A�ucar/ /media/disk/backups/

cp: não é possível executar stat `/media/disk/backups/Morangos Com A\347ucar': Caractere largo ou multi-byte é inválido ou está incompleto

(sim, aparece mesmo o ? no Açucar)

Alguma sugestão?

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
djthyrax    11
djthyrax

Eu sugeria-te deixares de usar esse tipo de caracteres. Às vezes os nomes não ficam muito legíveis, mas evita problemas.

E vou renomear centenas de ficheiros? Não me parece...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
djthyrax    11
djthyrax

Todos de uma vez talvez não, mas aos poucos talvez seja boa ideia.

Tendo em conta que tenho 40GB de files para fazer backup para formatar a unidade, não é opção.

Bem, I guess que vou ter de codar qq coisa para mudar o nome para utf-8 e mover...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
djthyrax    11
djthyrax

Não consegues por isso dentro de um tar ?

Not the point, o objectivo era mesmo copiar a estrutura porque enquanto faço manutenção a vários discos, vou organizando as cenas e n tenho espaço para tar + files. E, duvido que o tar funcionasse a extrair para ntfs.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
mogers    14
mogers

Eu sugeria-te deixares de usar esse tipo de caracteres. Às vezes os nomes não ficam muito legíveis, mas evita problemas.

E vou renomear centenas de ficheiros? Não me parece...

És um programador não és? Faz um programa que te renomeie os ficheiros  :D  Para cada ficheiro verifica os caracteres acentuados e os 'ç'    :)

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
djthyrax    11
djthyrax

mount -t vfat -o codepage=850,iocharset=iso8859-1,noexec /dev/hdaX /media/disk-1/Athlon64  ?

Não ia funcionar :D

Eu sugeria-te deixares de usar esse tipo de caracteres. Às vezes os nomes não ficam muito legíveis, mas evita problemas.

E vou renomear centenas de ficheiros? Não me parece...

És um programador não és? Faz um programa que te renomeie os ficheiros  ;)  Para cada ficheiro verifica os caracteres acentuados e os 'ç'    :)

Era isso que eu ia fazer até o CR_ me dizer para tentar usar nas partições FAT pôr utf8 como iocharset. :)

Tks a lot, solved.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade