Ir para o conteúdo
Triple

[Instalar Biblioteca]Curl

Mensagens Recomendadas

Triple    0
Triple

Boas,

Não sabia onde colocar esta minha duvida  :cheesygrin: Por isso meti aqui, se estiver errado por favor movam o tópico.

Bom, o problema é o seguinte, tenho um script que utiliza a biblioteca curl que até vi cá no p@p e adaptei  :D Mas o meu novo servidor não possui esta maravilhosa lib. o SO do servidor é Linux portanto fiz

./configure

make

make install

Mas sei que devo fazer mais qualquer coisa... pois não funcionou... alterar o php.ini? Já vi que podemos incluir isto quando estamos a compilar o PHP mas este já está compilado e instalado.

Cumps

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Triple    0
Triple

Já fiz isso e reiniciei já meti libcurl.so que é um file que tenho no mesmo sitio do php.ini que está em

/usr/local/lib

;Windows Extensions

;Note that MySQL and ODBC support is now built in, so no dll is needed for it.

;

extension=libcurl.so

já tive isso de várias maneiras... como disse acima.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Triple    0
Triple

CentOS.

Li um tutorial que dizia --with-curl=../curl-7.12.2 enquanto estivessemos a compilar o php mas este já está instalado =X

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Triple    0
Triple

Epá, compila o php again. Eu não tenho experiência em configuração do PHP em unix.

n existe outra alternativa ao curl então? uma que n necessite de libs opcionais?

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
mota77    0
mota77

em centos basta pores "yum remove httpd-php" para remover

depois "yum install httpd-php" "yum install php-mysql"

e voaila tem o curl compilado logo... se precisares de ajuda eu possote fazer isso remotamente

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
mota77    0
mota77

ah esquecime depois tens de fazer

service httpd start

service mysqld start

depois se quizeres que eles iniciem sempre basta fazer

ntsyss e depois selecionares o httpd e o mysql...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Triple    0
Triple

Tentei isso mota77

Mas quando fiz o 1º comando apareceu

Setting up Remove Process

No Match for argument: httpd-php

No Packages marked for removal

Deduzo que tenha corrido mal =X

Se puderes adicionar era optimo assim explicavas melhor isso

Pedro_1234564@hotmail.com

Cumps

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade