• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

FlashTH

Adaptador Wireless em ubuntu: Como?

40 mensagens neste tópico

Olá.

Tenho um adaptador wireless da AUS. O ASUS 802.11G 54MBps.

Tenho instalado o Ubuntu 7.04. Como instalo nele a placa? No manual diz Windows nos requirimentos, mas no CD tem uma pasta linux.

Como ponho isto a bombar no ubuntu?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Experimenta ir a Sistema, administracao, rede, e ve se aparece la algo do tipo ligacao sem fios.

Se aparecer, carrega em propriedades, e define o ssid do AP e a sua chave, assim que fizeres fechar, ele aplica as definicoes e et voila.

Se nao aparece, entao nao sei.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Voiu tentar... Mas antes disso não é preciso instalar o hardware? Eu ligo o adap+tador ao PC e não acontece nada...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ok. No site da asus (http:/pt.asus.com) encontrei os drivers para a minha placa (WL-167g).

Ta aqui o link para os drivers: http://dlsvr02.asus.com/pub/ASUS/wireless/WL-167g/Linux_1218.zip

De acordo com o readme, a placa é uma rt73, pois fiz lsusb e deu isso.

Agora a dúvida: Como compilo e ionstalo os drivers? Quando faço cat usb/devices ou algo assim não acontece nada.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já que este topic está aberto, aproveito e esclarecem-me uma coisa.

Eu tenho um adaptador da SMC (SMCWUSB-G) e li noutro fórum que para instalar era preciso o ndiswrapper (acho que é este o nome) para instalar os drivers do penúria (também conhecido por Windows XP). Eu la segui o topic, fazendo tudo o que manda a regra, no entanto ja coloquei o nome da rede bem como a pass e nada... não consigo aceder a net (ele detecta 75% do sinal).

A minha duvida é: se ele detecta o sinal, já coloquei o nome da rede e pass, porque é que eu não tenho net?

Deixo aqui algumas informações que poderão ser úteis na resolução do problema:

$ lsusb

Bus 001 Device 002: ID 083a:4505 Accton Technology Corp.

$ sudo ndiswrapper -l

smcwgu : driver installed

device (083A:4505) present

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

não tens drivers de linux? O ndiswaper serve para emular drivers do XP, não sei se terá o mesmo efeito.

Já agora, pdoes dizer onde encontras-te um tutorial para meter o diswapper a funcionar?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

a mim aconteceu-me uma coisa esquisita:

emprestei o meu pc a minha namorada por 15 dias. Ela usou uma placa wireless pcmcia no windows.

Quando cheguei liguei o computador e fiz um update. Reparei que as lizitas da placa estavam a piscar. Experimentei inserir a chave de desencriptação e... voila! Estava a funcionar.

Moral da historia:O update deu conta do hardware até então não suportado.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

A minha duvida é: se ele detecta o sinal, já coloquei o nome da rede e pass, porque é que eu não tenho net?

Provavelmente não configuraste os servidores de DNS e afins. ;)
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

FlashTH, eu utilizei isso porque não encontrei os drivers para linux, como não os encontrei, utilizei isso como ultimo recurso. Em relação ao tutrial, eu segui este (apartir do 3º post) e este (o 1º post).

Entretanto falei com o vbmaster no irc, e o meu problema deve estar relacionado com o WEP e WPA.

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não consegui por o ndiswarpper ,a dar. Mas eu tenho drivers dfe linux, mas não consigo compilar. ALGUÉM PODE AJUDAR? TOU A FICAR DESESPERADO!

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Qual é a informação que te dá ao compilares os drivers?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não dá erro, eu simplesmente não sei compilar os drivers. Tenho o ubuntu á 4 dias.

Já fiz make, make install, configure, nada dá.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Então extrai os ficheiros compactado (em .tar.gz), e entre os ficheiros extraídos deve estar um ficheiro README. basta leres isso e seguir os passos.

Convém referir que quando aparece o $ é para executares os comandos em utilizador normal, e quando aparecer o # é para ser executado como root.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu sigo os passos mas ao ffazer cat proc/usb/devices dá erro.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Olá de novo.

Tentei de novo instalar os drivers, mas quando chego ao passo 3 dá erro. Naquele onde dis o kernel 2.4 ou 2.6. Afinal como eu vejo qual é o meu? Tenho o Ubuntu 7.04.

O adaptador é o WL-167G, modelo rt73.

Drivers: http://dlsvr02.asus.com/pub/ASUS/wireless/WL-167g/Linux_1218.zip

Ninguém sabe copmo compilar e instalar os drivers?

Quero migrtar para o linux, mas sem net não dá.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O teu kernel é o 2.6, podes ver isso fazendo uname -a numa consola.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tens lá os readme.

Primeiro vês o modelo. Mete-no na entrada usb e faz lsusb. Assumindo por exemplo que é o rt25USB.

Descompactas tudo e vais pela consola até a pasta RT25USB-SRC-V2.0.7.0

$chmod 755 Configure

$cp Makefile.6 Makefile  *

(é provável que precises de instalar o pacote build-essential que vem com o cd, basta meteres o cd e fazeres na consola #sudo aptitude install build-essential )

$sudo make

(se der erros não avances e mete o log aqui)

etc. (o resto está lá no README)

* O teu kernel é 2.6.20 como podes constatar pelo comando uname -r se puseres na consola, ou no inicio do grub quando escolhes o SO, normalmente no nome está escrito que kernel vai fazer boot.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O adaptador é um rt73, como diz no lsusb.

Eu li o readme mas nao consegui. Vou tentar outra vez. Tenho de escrever sempre "$" antes dos comandos?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu li o readme mas nao consegui. Vou tentar outra vez. Tenho de escrever sempre "$" antes dos comandos?

Não. O $ não se escreve. o $ é só para dizer que é para executar aquilo como utilizador normal. :(
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

fiz #cp Makefile.6 Makefile (teve de ser com sudo, senao nao dava)

$chmod 755 Configure

quando chego a parte do make config ele diz que não tem nenhum arquivo alvo.

Já tenho os bluid essencials instalados.

Não podes tentar compilar tu para ver?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

=======================================================================

Build Instructions: 

====================

1> $tar -xvzf RT73_Linux_STA_Drv_x.x.x.x.tar.gz

    go to "./RT73_Linux_STA_Drv_x.x.x.x/Module" directory.

   

2> $cp Makefile.6  ./Makefile

4> $make all            # compile driver source code

5> $cp rt73.bin /etc/Wireless/RT73STA/     # copy firmware

6>  $dos2unix rt73sta.dat

    $cp rt73sta.dat  /etc/Wireless/RT73STA/rt73sta.dat     

    # !!!check if it is a binary file before loading !!! 

7> $load 

    #[kernel 2.6]

    #    $/sbin/insmod rt73.ko

    #    $/sbin/ifconfig rausb0 inet YOUR_IP up

=======================================================================

CONFIGURATION: 

====================

RT73 driver can be configured via following interfaces,

i.e. (i)"iwconfig" command, (ii)"iwpriv" command, (iii) configuration file

    (iv)RaConfig

i)  iwconfig comes with kernel. 

ii) iwpriv usage, please refer to file "iwpriv_usage.txt" for details.

iii)copy configuration file "rt73sta.dat" to /etc/Wireless/RT73STA/rt73sta.dat.

iv) RaConfig is utility for rt73.

Tirado do README. :(

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, eu segui oas passos do readme. Mas não consegui fazer $make all.

EDIT: Quando diz # a frende dos comandos tem de ser como root?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

EDIT: Quando diz # a frende dos comandos tem de ser como root?

Sim, tens de ser root para executar comandos que têm "#" antes dos comandos...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora