• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Bruno

As minhas aventuras no Ubuntu...

20 mensagens neste tópico

Deixo aqui a minha aventura com a versão 7 do Ubuntu. Caso alguém esteja interessado em tentar ajudar poderei sempre voltar a tentar meter as coisas bem :)

Há uns anos usei o Ubuntu 4 por volta de 2 meses, no entanto, os trabalhos da universidade em C# (Visual Studio) obrigaram-me a voltar ao XP e a verdade é que voltei a “esquecer” Ubuntu até à versão 7. Esta versão foi muito elogiada e aí voltou a minha vontade de experimentar e tentar novamente transitar.

Infelizmente possuo componentes “fora do normal” tais como 2 monitores (1 deles maior que 23”), placa gráfica recente (8800 GTS), teclado bluetooth, entre outros… Hardware esse que tem pouca documentação/ajuda online sendo complicado dar com as configurações correctas.

Como esperava aconteceram diversos problemas… tive que instalar em modo de texto, tive 3 horas a tentar meter os drivers da NVIDIA a funcionar para depois descobrir que havia alguns conflitos com o que fiz (embora pelo que li era o único modo de meter a dar). Sendo assim e embora a NVIDIA tenha feito uns drivers fantásticos a verdade é que não funcionavam muito bem com o Ubuntu e em vez de um sistema rápido fiquei com um sistema lento.

Com a falta de tempo (e pachorra) volto adiar a transição, de qualquer modo ao ritmo que o Ubuntu está avançar (vi isso da versão 4 para a 7) acho que será para breve a minha nova tentativa. No entanto, fiquei com pena… pois embora até tenha conseguido superar os problemas não fiquei com o que esperava e sem dúvida que tal aconteceu devido a todas as soluções “que tive que aplicar” para o meter a funcionar.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

apresentaste as principais razões para eu não me dedicar ao linux... principalmente a não existência de drivers para o hardware mais recente e mesmo para o mais antigo, torna-se dificil colocar a funcionar... quase que tem de se tirar um curso de linux para colocar um simples modem pcmcia a funcionar...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

apresentaste as principais razões para eu não me dedicar ao linux... principalmente a não existência de drivers para o hardware mais recente e mesmo para o mais antigo, torna-se dificil colocar a funcionar... quase que tem de se tirar um curso de linux para colocar um simples modem pcmcia a funcionar...

A minha namorada com um pc comprado há 1 ano e meio tem tudo a funcionar sem ter tido necessidade de configurar algo! :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

só posso chegar a uma conclusão: teve sorte com o hardware...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

apresentaste as principais razões para eu não me dedicar ao linux... principalmente a não existência de drivers para o hardware mais recente e mesmo para o mais antigo, torna-se dificil colocar a funcionar... quase que tem de se tirar um curso de linux para colocar um simples modem pcmcia a funcionar...

Eu discordo. Então eu tenho o ubuntu em 2 desktops e no portátil tendo um desktop 7 anos e outro 2, com todo o hardware a funcionar, e no portátil facilmente acedo a uma ligação wireless, partilho as pastas com pc's windows muito mais rapidamente do que windows-windows, jogo tudo o que jogava em windows.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu no meu PC consigo ter todo o hardware a funcionar, mas o hardware mais esquisito que tenho são o rato e o teclado, que são bluetooth...

Mas mesmo esses em meia dúzia de minutos na consola são suficientes para os pôr a funcionar :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

instalem mas é uma distribuição decente  :D tipo gentoo ou debian.

(não sei porquê nunca achei piada ao Ubuntu...)

neste momento tenho o Debian e o OpenSuse com todo o hardware a funcionar. o que deu mais trabalho foi mesmo a impressora e o scanner, de resto, não foi nada de mais (não tenho hardware topo de gama, mas em contrapartida tenho um SO topo de gama  :P).

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

aí está, vocês acabam por referir exactamente o que afasta as pessoas do linux... se quem sabe de informática anda um pouco às aranhas para pôr um computador a bulir na totalidade, o que fará quem não sabe... eu para conseguir instalar o modem do kanguru estive 3 dias, e era com a ajuda de 2 prós em linux... tive que instalar exactamente o ubuntu porque foi a unica distro que se conseguiu configurar com o modem... para aceder à net, tenho de usar o modprobe via consola e depois abrir o gnome ppp, tudo como root... um utilizador comum não quer nada destas coisas... quer chegar, instalar o hardware, instalar drivers se necessários e a seguir limitar-se a dar dois clicks para ter a coisa a trabalhar...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu tenho uma placa TV mas no linux é mentira, não há tv para je, quero ver tv, vou pro windows :D

Já ag é uma REAL TV TOP 10 e tou com Ubuntu 7.04, se alguém souber meter isto a bulir, era uma mais valia :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu tenho uma placa TV mas no linux é mentira, não há tv para je, quero ver tv, vou pro windows :D

Já ag é uma REAL TV TOP 10 e tou com Ubuntu 7.04, se alguém souber meter isto a bulir, era uma mais valia :P

Faz lspci para ver qual o chipset da qual placa e mete aqui. De qualquer pelo google pareceu-me que era igual esta: http://ubuntuforums.org/showthread.php?t=332837

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

CR_ assim que chegar a casa experimento isso e digo qq coisa :D

Obrigado.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Esta discussão é um pouco repetitiva, está por todo lado nestes e noutros fóruns.

Ainda assim tenho a dizer que vou fazendo os updates ao meu ubuntuzinho e tenho constatado uma coisa. Esta distribuiçao está a fazer um grande trabalho precisamente no problema dos drivers. Não vale a pena negar, o windows é compativel com muito mais hardware. O ubuntu está finalmente a mudar um pouco isso.

Há tempos fiz uma actualização e voila.... a minha placa wireless pcmcia, muito velhinha, pura e simplesmente funcionou sem necessitar de qq configuração. Tem hotplug e tudo :D

Ainda bem que estamos a caminhar para menos uma barreira.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ontem tentei meter o ubuntu no meu pc servidor e fiquei espantado ao ter dado tudo à primeira (mesmo os "efeitos de desktop") excepto a internet. De reparar que tenho as ligações mto "esquesitas" uma vez que o servidor liga-se directamente ao modem por uma placa de rede e por outra ao router. Surpreendentemente consegui configurar tudo (incluindo o dar net) em 1h e 30m, coisa que no XP a 1ª vez demorou 4h. ;)

Só tenho mm pena n ter conseguido meter a dar no meu pc normal :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Realmente a minha parece ser igual a essa que mostras-te

Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)

mas fiz os comandos que ele diz, mas dá erro:

root@nautilus:/etc/modprobe.d# sudo echo "option cx88xx card=4 tunner=44" > cx88xx

root@nautilus:/etc/modprobe.d# modprobe -r cx8800

WARNING: /etc/modprobe.d/cx88xx line 1: ignoring bad line starting with 'option'

root@nautilus:/etc/modprobe.d# modprobe cx8800

WARNING: /etc/modprobe.d/cx88xx line 1: ignoring bad line starting with 'option'

Alguma solução ?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O Tvtime liga e aparece a imagem em areia "estatica" mas como faço scan de canais ?

EDIT: Agora que olhei para a consola, tava lá assim:

A correr tvtime 1.0.2.

A ler a configuração de /etc/tvtime/tvtime.xml

I/O warning : failed to load external entity "/home/leon/.tvtime/tvtime.xml"

I/O error : Permission denied

I/O error : Permission denied

Não foi possível alterar o dono de /home/leon/.tvtime/tvtime.xml: Permissão negada.

videoinput: Can't get tuner info: Argumento inválido

videoinput: Can't get tuner info: Argumento inválido

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O Tvtime liga e aparece a imagem em areia "estatica" mas como faço scan de canais ?

para o scan: channel management -> scan channel for signal

um conselho, vê se consegues por o kdetv a funcionar, acho que é bem melhor do que o tvtime.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

thread digging

ja toda a gente brincava comigo por ainda usar o dapper drake.

como ja estava farto de ter o meu disco todo fatiado, reparticionei-o e instalei o feisty usando o meu disco todo! Finalmente removi o windows! :)

Curiosidade... a primeira coisa qe instalei... as fonts da microsoft :D o ponto mais negativo das distros linux que conheco...

Ate agora ainda nao encontrei grandes diferencas entre o dapper.

Alguem se lembra onde é que se adiciona um layout de teclado?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Alguem se lembra onde é que se adiciona um layout de teclado?

Sistema ---> Preferências ---> Teclado ---> tab Disposição

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Peço desculpa por utilizar este tópico mas o meu problema também é de mais uma aventura que deu mau resultado em Ubuntu Feisty.

O que aconteceu é que alterei o meu bootsplash e ficou tudo a funcionar lindamente, no entanto à coisa de uma semana instalei os updates que me apareceram aqui, e de repente começou a não dar e fica um bocado do bootsplash a preto. Ora bem o que acontece é que agora quero tirar e pôr o default mas não sei, alguém me pode ajudar?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O Tvtime liga e aparece a imagem em areia "estatica" mas como faço scan de canais ?

EDIT: Agora que olhei para a consola, tava lá assim:

A correr tvtime 1.0.2.

A ler a configuração de /etc/tvtime/tvtime.xml

I/O warning : failed to load external entity "/home/leon/.tvtime/tvtime.xml"

I/O error : Permission denied

I/O error : Permission denied

Não foi possível alterar o dono de /home/leon/.tvtime/tvtime.xml: Permissão negada.

videoinput: Can't get tuner info: Argumento inválido

videoinput: Can't get tuner info: Argumento inválido

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

I/O error : Permission denied

Diria que é capaz de faltar um sudo. Por isso é que te dá permissão negada.

Quanto à configuração, eu tive alguns problemas por causa da placa ATI, e da webcam. mas de resto seguindo os tuturiais consegui chegar a bom porto. E não me arrependo nada de usar Linux. Foi a melhor coisa que fiz.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora