• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

mpeixoto

Ubuntu 7.04 não instala o grub

6 mensagens neste tópico

No final da instalação da erro: "a execução 'grub-install /dev/MBR' falhou. primeiramente tinha tentado no 'hda0' e tambem deu erro.

Eu com o live-cd fiz "sudo grub-install" mas nada feito. Deu erro com o /boot. é preciso montar o /boot?

Alguem me pode dizer como instalar o grub?

cumps

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ubuntu@ubuntu:/boot$ sudo fdisk -l

Disk /dev/hda: 250.0 GB, 250059350016 bytes

255 heads, 63 sectors/track, 30401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start        End      Blocks  Id  System

/dev/hda1  *          1      27851  223713126    7  HPFS/NTFS

/dev/hda2          27852      27887      289170  82  Linux swap / Solaris

/dev/hda3          27888      30401    20193705  83  Linux

ubuntu@ubuntu:/boot$

ubuntu@ubuntu:/boot$ sudo grub-install /dev/hda3

Could not find device for /boot: Not found or not a block device.

ubuntu@ubuntu:/boot$

Tambem segui o artigo do guiubuntupt e tambem nao funciona

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não é hda3, é só hda.

Está bem explicito no link na parte " Restaurar o Grub a partir de um live-cd".

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Está bem explicito na parte em que eu digo: "Tambem segui o artigo do guiubuntupt e tambem nao funciona"

sudo grub install /dev/hda

      [ Minimal BASH-like line editing is supported.  For

        the  first  word,  TAB  lists  possible  command

        completions.  Anywhere else TAB lists the possible

        completions of a device/filename. ]

grub> find /boot/grub/stage1

Error 15: File not found

grub>

grub> root (hd0,1)

grub> setup (hd0)

Error 17: Cannot mount selected partition

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Problema resolvido!

Voltei a instalar de novo mas desta vez com o cd que mandei vir da net que chegou hoje!

Obrigado pela ajuda na mesma!

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora