• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

aluminium

Kanguru no Ubuntu

50 mensagens neste tópico

Boas,

Estou com uma grande dificuldade em instalar o modem USB E220 do Kanguru no Ubuntu. Já pesquisei no Google e o que encontrei, nada funciona.  :rant_01:

A opção ttyUSB0 ou 1... não aparece, mas sim ttyS0 ou 1...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o "modprobe usbserial vendor=0x.... product=0x...." não te cria as ttyUSB0 e 1?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

onfelizmente os modems usb não costumam vir com drivers de jeito para linux. Eu tinha um icedata500 e aquela porra só era compatível com kernels de há 4 anos ou coisa que o valha.

Essa é na minha opiniao um dos pontos onde o windows marca pontos, o hardware tem quase todo suporte para windows, enquanto que para linux já não é bem assim. Eu arranjei um router usado, de qq das formas precisava de ligar mais do que um pc à internet...

Mas é triste ter que se investir em hardware por causa dos fabricantes terem atitudes deste tipo.

Bem, desculpa não ajudar, mas ainda dava mais uns dois anitos até começar a haver suporte de jeito para um leque maior de hardware. Tambem os ISPs portugueses, já que são tão careiros, podiam começar a trazer hardware mais amigável em vez de impingir a maior sucata que encontram.

A boa noticia é que quando isso funcionar em condições em linux o ubuntu será provavelmente uma das primeiras distribuições a oferecer suporte, mantem os updates em dia :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

onfelizmente os modems usb não costumam vir com drivers de jeito para linux. Eu tinha um icedata500 e aquela porra só era compatível com kernels de há 4 anos ou coisa que o valha.

Essa é na minha opiniao um dos pontos onde o windows marca pontos, o hardware tem quase todo suporte para windows, enquanto que para linux já não é bem assim. Eu arranjei um router usado, de qq das formas precisava de ligar mais do que um pc à internet...

Mas é triste ter que se investir em hardware por causa dos fabricantes terem atitudes deste tipo.

Bem, desculpa não ajudar, mas ainda dava mais uns dois anitos até começar a haver suporte de jeito para um leque maior de hardware. Tambem os ISPs portugueses, já que são tão careiros, podiam começar a trazer hardware mais amigável em vez de impingir a maior sucata que encontram.

A boa noticia é que quando isso funcionar em condições em linux o ubuntu será provavelmente uma das primeiras distribuições a oferecer suporte, mantem os updates em dia :cheesygrin:

Já me lembrei de mandar 1 mail a reclamar a falta de suporte para Linux.

Depois temos de usar o windows, que remédio...

Tens driveres para win9x disso?

Não, mas porquê?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já me lembrei de mandar 1 mail a reclamar a falta de suporte para Linux.

Manda :cheesygrin:

Não, mas porquê?

Porque existiam umas manhosisses com alguns drivers de win9x de uma placas wireless que dava para correr em linux. :P
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Porque existiam umas manhosisses com alguns drivers de win9x de uma placas wireless que dava para correr em linux. :cheesygrin:

Mas só há para xp e 2000. Pelo menos eram só esses que vinham.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mas só há para xp e 2000. Pelo menos eram só esses que vinham.

Procura no site do fabricante por drivers pa linux. :cheesygrin:
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Muita gente anda a perguntar como instalar este modem no linux.

O grande problema é que quando se liga ao PC é reconhecido como um usb-storage device e não como um usbserial. Logo para ter acesso ao modem tem de se configurar o modulo usbserial para o productid e vendorid do dispositivo.

Ligar o dispositivo ao pc. Se o linux ter feito mount automatico devem fazer unmount.

Executar os seguintes comandos como user root:

# rmmod usb-storage
# rmmod usbserial

Depois verificar qual é o vendedorid e o productid do disposivo:

# lsusb

ou

# cat /proc/bus/usb/devices

Depois é dizer que se deve carregar o modulo usbserial para este dispositivo:

# modprobe usbserial vendor=<vendedorid> product=<productid>

ex:

# modprobe usbserial vendor=0xaf0 product=0x5000

depois disto devem ter um novo node:

# ls /dev/ttyUSB*
/dev/ttyUSB0

depois disto é só usar um programa de ppp para fazer a ligação.

para ficar definitivamente as configurações do modem sempre que ligá-lo basta colocar em /etc/modules.conf:

options usbserial vendor=0xaf0 product=0x5000

Isto faz com que sempre que for ligado este dispositivo seja usado o modulo usbserial em vez do usb-storage

Seja como for tive algumas dificuldades em ligar à internet. Foi preciso algumas repitições destes passos e assim como quem não quer a coisa lá dava :-D

Uma coisa interessante é que nem sequer é preciso PIN.

# vim /etc/wvdial.conf 

[Dialer Defaults]
Phone = *99***1#
Username = username
Password = password
Stupid Mode = 1
Dial Command = ATDT

[Dialer pin]
Init1 = AT+CPIN=0000

[Dialer 3gonly]
Init4 = AT+COPS=0,0,"",2

[Dialer huewai_e220]
Modem = /dev/ttyUSB0
Baud = 460800
Init2 = ATZ
Init3 = ATE0V1&D2&C1S0=0+IFC=2,2
ISDN = 0
Modem Type = Analog Modem

Para testar basta:

# pon.wvdial huewai_e220
# poff.wvdial

se quizerem usar a opção pin:

# pon.wvdial huewai_e220 pin

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Segui todos os passos do post, mas continua a não funcionar, se bem que desta vez, detectou o modem e parece estar tudo direito, apenas não consegue passar da fase de ligação.

Fica aqui o print:

debiankanguruer2.th.jpg

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Com o gnome-ppp não me consegui ligar quando testei agora não tenho o kanguri para ver novamente.

Mas tu já tens comunicação com o Modem dado que está a responder. Portanto já não é uma questão de problema com drivers ou hardware mas sómente configuração.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Pois, realmente ele já comunica, o que não fazia. Talvez o username e a password não estejam bem, mas é que eu não recebi nada com essa informação! Qual é o user e pass que utilizas?! o "myconnection"?

Outra coisa, como faço a ligação sem ser com o gnome-ppp?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

está lá escrito os scripts

para conectar: pon.wvdial

para disconectar: poff.wvdial

O username e password não são usados é mesmo literal podes meter o que quizeres  :P. Mas testa a configuração como eu escrivi aqui e depois diz o que te aconteceu.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Voltei a tentar, mas desta vez não detectava o modem.

Segui novamente todos os passos, e lá consegui detectar o modem, mas quando vou fazer a ligação diz que o modem não está a responder. :S

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Certo. Também me aconteceu como disse tive de repetir algumas vezes. Ainda não percebi a razão do que faz ou não funcionar umas vezes e outras não.  Mas neste momento não tenho Kanguru para voltar a testar pois tinha sido um colega meu que tinha Linux e essa placa pediu-me na altura para ver se metia a funcionar.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

aluminium olha eu estou a tentar por o kanguru no archlinux ... nem comunicar com o modem consigo, só encontro cenas para o ubuntu :(

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu estava com o mesmo problema, depois de instalar o Gnome-PPP, ficou tudo bem. Se ainda assim não der, tenta tirar a placa, voltas a inseri-la e tenta a ligação através do Gnome novamente. Acontece-me muitas vezes.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

aluminium, já conseguis-te ter acesso á internet???

É que agora é comigo... vou ver se consigo instalar o modem no ubuntu 7.04...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

aluminium, já conseguis-te ter acesso á internet???

É que agora é comigo... vou ver se consigo instalar o modem no ubuntu 7.04...

Depois de tentar com a versão anterior do Ubuntu e nada ter conseguido, passei a matar a cabeça em Debian 4.

Foi por pouco que não consegui. Havia ali qualquer coisa a falhar. Eu provavelmente :thumbsup:

Quando saiu o Ubuntu 7.04, então aí voltei a tentar. Fiz tudo novamente e deu à primeira.

A placa gráfica (ATI X1400) e a placa wireless (IPW3945ABG) também estão a funcionar 5*.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

:rant_01:

Pois eu não consigo...

Primeiro experimentei fazer isto:

http://www.guiaubuntupt.org/wiki/index.php?title=Kanguru/Placa_USB_HUAWEI

Não deu em nada

Depois fiz aquilo que o Kimus disse:

Muita gente anda a perguntar como instalar este modem no linux.

O grande problema é que quando se liga ao PC é reconhecido como um usb-storage device e não como um usbserial. Logo para ter acesso ao modem tem de se configurar o modulo usbserial para o productid e vendorid do dispositivo.

Ligar o dispositivo ao pc. Se o linux ter feito mount automatico devem fazer unmount.

Executar os seguintes comandos como user root:

# rmmod usb-storage
# rmmod usbserial

Quando fiz o rmmod usb-storage deu-me este erro "Removing 'usb-storage': operation not permited", depois digitei rmmod usbserial e deu-me outro erro "Module usbserial is in use by option"....

Existe algum problema aqui?? Há outra coisa, para aceder á consolo basta ir ás aplicações e clicar na consola, certo????  :-[ Eu a linux sou um 0 dos grandes....

Depois verifiquei o vendorid e o productid não fiz com os comandos que o Kimus disse, foi antes ao gestor de dispositivos...

De seguida fiz como sugerido:

Depois é dizer que se deve carregar o modulo usbserial para este dispositivo:

# modprobe usbserial vendor=<vendedorid> product=<productid>

ex:

# modprobe usbserial vendor=0xaf0 product=0x5000

Eu como não retornou nenhuma mensagem isso quer dizer que estava tudo bem certo?? Li isso em algum lugar que "no news is good news"...

Mas quando foi á procura do modules.conf não encontrei este ficheiro só me aparece modules... este modules.conf parece-me mais um ficheiro do Windows...

E pronto fiquei por aqui... não avancei mais, também fiquei na duvida com respeito ao gnome-ppp e como poderia fazer a ligação da internet...

Desde já agradeço a ajuda, porque quando toca ao Linux não pesco nada.

Cumps,

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora