• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

ber0x88

[Resolvido] Wine BadAlloc

6 mensagens neste tópico

olá pessoal...  ;)

Após uns anos a usar window$  :wallbash: decidi definitivamente encaixa-lo bem na gaveta e começar a usar o Ubuntu 6.06 Dapper Drake... não sei se foi a melhor escolha para um iniciante... mas o que é certo é que estou a gostar muito de trabalhar com ele... mas surgiram-me uns erros com alguns programas... os erros são os seguintes:

Instalei o wine para conseguir emular alguns programas do windows mas o que é certo é que ainda n consegui emular nenhum sem dar erros... e ao tentar emular este dá o seguinte erro...

diablo@diablo-desktop:~/ewb$ wine WEWB32.EXE

X Error of failed request:  BadAlloc (insufficient resources for operation)

  Major opcode of failed request:  53 (X_CreatePixmap)

  Serial number of failed request:  20534

  Current serial number in output stream:  20577

o que posso fazer para por o programar a ser bem emulado sem erros???

e já agora no synaptic ao fazer recarregar aparece-m o seguinte erro:

Os seguintes problemas foram encontrados no seu sistema:

W: GPG error: http://wine.budgetdedicated.com dapper Release: As seguintes assinaturas não puderam ser verificadas porque a chave pública não está disponível: NO_PUBKEY 58403026387EE263

também gostaria de resolver este problema...

Fico a espera de ajuda...

:)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Instalei o wine para conseguir emular alguns programas do windows mas o que é certo é que ainda n consegui emular nenhum sem dar erros... e ao tentar emular este dá o seguinte erro...

só um pequeno pormenor, o WINE não é um emulador (Wine Is Not an Emulator)!


EDIT: vê se isto ajuda: http://bugs.winehq.org/show_bug.cgi?id=3826

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ya tens razão Rui Carlos!!!

bahhahahha agora tou com outro problema!!! isto dos pacotes em deb...

diablo@diablo-desktop:~$ sudo apt-get -f install

Password:

A Ler Listas de Pacotes... Pronto

Construindo Árvore de Dependências... Pronto

Corrigindo dependências... falhou.

Os pacotes a seguir têm dependências não satisfeitas:

  firestarter: Depende: libavahi-client3 (>= 0.6.13) mas 0.6.10-0ubuntu3.4 está instalado

              Depende: libavahi-glib1 (>= 0.6.12) mas 0.6.10-0ubuntu3.4 está instalado

              Depende: libcairo2 (>= 1.2.4) mas 1.0.4-0ubuntu1 está instalado

              Depende: libdbus-1-3 mas não está instalável

              Depende: libfreetype6 (>= 2.2) mas 2.1.10-1ubuntu2.2 está instalado

              Depende: libgnutls13 (>= 1.4.0-0) mas não está instalável

              Depende: libgpg-error0 (>= 1.2) mas 1.1-4 está instalado

              Depende: libpopt0 (>= 1.10) mas 1.7-5 está instalado

              Depende: libtasn1-3 (>= 0.3.4) mas não está instalável

              Depende: libxml2 (>= 2.6.26) mas 2.6.24.dfsg-1ubuntu1 está instalado

  libatk1.0-0: Depende: libglib2.0-0 (>= 2.12.0) mas 2.10.3-0ubuntu1 está instalado

  libc6: Depende: tzdata mas não está instalável

  libc6-dev: Depende: libc6 (= 2.3.6-0ubuntu20.4) mas 2.3.6.ds1-11 está instalado

  libc6-i686: Pré-Depende: libc6 (= 2.3.6-0ubuntu20.4) mas 2.3.6.ds1-11 está instalado

E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).

E: Impossível corrigir dependências

n sei como eide corrigir isto... ja expeimentei com o synaptic no Edit >> fix all broken packages

mas só dá o seguinte erro:

E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).

E: Unable to correct dependencies

não queria era ter de formatar outra vez... :nono1:

assim n consigo instalar/remover nada a partir do synaptic... diz sempre pra corrigir primeiro os pacotes quebrados...

:wallbash:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Diablo instalas-te algum pacote sem ser dos repositórios?

Se sim saca o pacote dos repositórios, instala por cima e no fim #apt-get install -f

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ya tinha instalado sem ser dos repositorios... ja tenho o problema resolvido... Instalei o Ubuntu 6.10 porque eu tinha o 6.06... e agora tá tudo a funcionar as mil maravilhas... mas obrigado na mesma...  :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora